Car

Ask a mechanic online and get answers to your car questions

Ask an Expert,
Get an Answer ASAP!

This answer was rated:

No spark at plugs but it cranks. 2005 Jeep Liberty 6 3.7.

No spark at plugs...

No spark at plugs but it cranks

Mechanic's Assistant: What is the model/year of your Jeep?

2005 Jeep Liberty 6 3.7

Mechanic's Assistant: Are you fixing your Liberty yourself? What have you tried so far?

Yes, checked codes had oil psi replaced unit removed and reinstalled crank sensor checked all fuses ans relays and fuel

Mechanic's Assistant: Are you certain it's the fuel pressure sensor that's in need of attention? What about the fuel rail? Have you checked it yet?

Dont have psi tester for fuel yet but one on order but did check the test port for psi with drive an have flow during eng durn and after but don't know if meets min

Show More
Show Less
Ask Your Own Car Question
Customer reply replied 6 months ago
jeep was going down road as reported by my daughter all good then started puttering and died as if starved for fuel tried to start it, it cranked and almost started but battery died, checked it at stores and replaced with new one, tried again and same issue had it towed to my home and checked oil found low 2 quarts filled up found code as oil psi, replaced psi sensor, placed on order crankshaft sensor and camshaft sensor as none in my town. also placed on order a psi fuel checker as none in town but did check to see if it was getting fuel by opening check port fuel shot out when cranking, a compression checker wad ordered but not checked yet. also order a ASD relay as i pulled it and looked ok and seams to work? i check all fuses with tester all seam to work ok. checked spark plugs with tester it lights one time at start of crank but never again
Answered in 59 minutes by:
11/18/2017
Michael Solis
Category: Car
Satisfied Customers: 457
Experience: Lead Tech at Solis Auto Repair
Verified

Hello, my name is***** will be helping you out! I have over thirteen year of experience in the automotive industry for numerous different makes & models. I enjoy doing what I do, it is my life.

The next step I want you to check is if it has injection pulse or not, it plays an important roll as well for it can be the auto shut down relay if it lacks injection pulse

Ask Your Own Car Question
Customer reply replied 6 months ago
I have a new set of injectors I tried one as I do not want to remove parts until I find the underlining problem but when I check the one new one it operated the same one spark and then nothing during the cranking

Ok, are you saying the pusle stopped as well as spark since you heard the injector stop?

Ask Your Own Car Question
Customer reply replied 6 months ago
Sorry I was incorrect I was referring to coils not injectors I will need to get node light I will see if our local Napa has one

That would be the best option :). If not, you can always use a test light, but that does get more complicated to explain how to do it.

Ask Your Own Car Question
Customer reply replied 6 months ago
I will hit you up after I get one

Sounds good :)

Ask Your Own Car Question
Customer reply replied 6 months ago
Ok I live on kodiak island ak only 2part stores they did not have node test kit but I was able to use a light test unit on all of the units/fuel injectors and all worked pulse on off on off each good. I then did the same to each of the ignition coil electric plugs and found that only the center ones on each side was getting a pulse so I hooked up a spark tester and the same results only the two center plug were firing and get in put?
Ok so injection pulse is good. Now, what are the voltage reading of each pin of the ignition coil on the ones that are working and on the ones that are not. You will need a voltmeter for this.
Ask Your Own Car Question

Key on engine off when testing the wires please.

Ask Your Own Car Question
Customer reply replied 6 months ago
Ok worked
Volt/m dc start check and worked down until I got reading on the 2. Scale front left and right at .042 and.051 center left and right at.046 and .055 and aft at left .042 rift at .048

ok that does not seem accurate at all

key on engine off the center one should have 12 volts on the RD/OR wire

I also want to know what the known BAD COIL circuit reads to see if it also reads 12volts on the RD/OR wire

Ask Your Own Car Question
Customer reply replied 6 months ago
Just rechecked make sure on dc and got no good reading on 2. Scale for any of the no fire plugs but did get reading for them on 200 m scale at 15.9 and on the good plugs reading on. 2. Scale was 15.9 each side

Are you putting the black lead to ground and the positive lead to each wire? the RD/OR wire shows 15? What about the other wire, does it have any voltage on the known good coil. Take a peek at this diagram and tell me which coil wires are the good coils based on the color wires. There is two wires per ignition coil, I need both wire readings. 15.9 does not seem accurate either. Put both leads on the battery it should show the same as what the battery is.

Ask Your Own Car Question
Customer reply replied 6 months ago
Ok Black lead to a ground I used the mount to the altantor/ red prob to each wire on the units set on volts doc 200 m scale right side front red line 2.5 yellow line .5 center good fire spark red line 2.5 yellow line .4 aft line red 2.9 yellow line .4 same reading other side
Key in on position not cranking I also tried using the black to battery ground and got red line 7.9 yellow line 1.1 on all positions

I think your reading the wrong volts. put both positive and negative leads to your battery, and adjust the volt switch until it tells you that the battery is around 12volts

Ask Your Own Car Question
Customer reply replied 6 months ago
The firing plugs should be number 3 & 4 but the colors drivers side center is sold blue and passagers side is blue with red stripe but one behind it also has same color?
What is the unit that controls the volts going to the coil? Cam/Crank sensor? Or the PCM/ECM

there is two, the red yellow wire is controlled by the auto shut down relay and fuse 8. the other wire is individually controlled by the PCM

Ask Your Own Car Question
Customer reply replied 6 months ago
I just went a got a new meter at the store also set at 200m to get reading key on black to ground almost all readings same front drivers side red wire 8.1 yellow 1. Center red drivers side 8.0 blue 1. Aft drivers side red 7.9 blue 1. Redid about the same on passagers side ?
Customer reply replied 6 months ago
I have ordered a new ASD relay but won't see it until Monday/Tuesday best and crank/cam sensor same issue as none in town. Form info provided can a ASD be bypassed for a test? Start or volt check?

It can, but we need to properly read the voltages on each wire of the coils. I do not see that will be the problem since you stated two of the coils are actually working. Im leaning more towards the PCM being bad, but I need accurate voltage readings to determine that.

Ask Your Own Car Question
Customer reply replied 6 months ago
I re checked each and when with doc set at 20 and not just turning eng on but cranking it over and checking I got front driver side red 10.1 other line 0 center driver side red 11.2 other 0 rear drivers side red 10.2 other 0 almost same on other side is that more along the line of what it should be? As on last test I only had eng on but was not turning it over.
Ok we can safely say the shut down relay is activating its circuit and no problem there. Now we need to test the ground circuit. Put your test light to power and let’s begin checking the other wires that showed 0. Crank the engine and see if the test light flashes on and off on each coil
Ask Your Own Car Question
Customer reply replied 6 months ago
I wish to make sure that the alogator clip on the test light hooked to the positive bus on the battery and point of the test light on each line on the wire going to the coil that reads 0 from last test?
Correct
Ask Your Own Car Question
Customer reply replied 6 months ago
Ok drivers Sid front coil light up one time out o 5 try's the center the same the aft 4 time out of 5 as for the passagers side never light up at all one any of them
How many total coils did not light up at all and how many total coils light up?
Ask Your Own Car Question
Customer reply replied 6 months ago
3 lighted up at least one time and 3 did not light up at all
The three that lit up do they still continue to light up while cranking? The ones that did not light up all are located on the passenger side?
Ask Your Own Car Question
Customer reply replied 6 months ago
The three that light up only do so when cranking with power on and not cranking none light up and the ones that did not light up at all are on the passengers side
Ok so the next step is to find out why all on one bank has no ground on the coils. Either be cam sensor or pcm issue let me do some more digging and I’ll get back to you
Ask Your Own Car Question
Customer reply replied 6 months ago
Roger I do have cam and crank on order when they come in I will install and get back to you on it

Ok sounds good let me know how it goes. It is leaning to the PCM as to being the problem, but we can do some more procedures if the cam/crank replacement does not work

Ask Your Own Car Question

If you have a chance, please leave me a rating so I can receive credit for the question, would mean so much to me :). We can still continue after rating.

Michael Solis
Category: Car
Satisfied Customers: 457
Experience: Lead Tech at Solis Auto Repair
Verified
Michael Solis and 87 other Car Specialists are ready to help you
Ask your own question now
Customer reply replied 5 months ago
Michael,
i just got back into town and have cam/crankshaft sensors along with fuel tester and compression tester kit. replaced both cam/crankshaft sensors completed a psi check on fuel system found it holding around 60psi and compression on All cylinders around 100 psi cold as I can not run eng yet. rechecked wires to ignition red hot with key in and other as before sporadic turning. do you think next step should the PCM/ECM replacement ?

I have answered quite a bit of questions since I have last seen you. I will need to back track and review this question again & get back to you shortly after. Should be sometime this afternoon

Ask Your Own Car Question

Does the check engine light come on?

Do you have 5 volts on the tps disconnected key on engine off? Check every pin of the connector and see if you get 5 v

Ask Your Own Car Question
Customer reply replied 5 months ago
check eng light is on,
on the tops plug i get 5.1 volts on the red wire the middle wire .01 and the far end wire red/blue 3.6 volts
i have removed the pcm/ecm got model # ordered a new one plug and play ready then reinstalled the ppm/ecm.

Does the check engine light come on? key on engine off?

Ask Your Own Car Question
Customer reply replied 5 months ago
key on eng off
three light on seat belt/oil light/ check eng but after 30 seconds the check eng light starts flashing

whats the codes?

Ask Your Own Car Question
Customer reply replied 5 months ago
found 508 code it's for idea sensor it was not locked down from when i was testing on the TPS a few minutes ago so locked it down cleared all codes rechecked got no codes as system has the word (donE) just as i spelled it and the 3 lights operated the same as prior but one thing i noted is every 30 sec or so a flash of a code seems to display but its so rapid and fast as i can not make out an #and it still displays (donE)

ok appears to be the PCM with the coil issues

Ask Your Own Car Question
Customer reply replied 5 months ago
Ok, i have one i ordered today when it get in i will install and let you know what's up
Darrin

ok sounds good

Ask Your Own Car Question
Customer reply replied 5 months ago
Michael,
the PMC came in to day i installed and gave it a try same no start, checked for spark both the center cylinders are firing the two forward get one fire each time and the two aft none? any ideas on what it could be?
Is the security light on?
Ask Your Own Car Question
Customer reply replied 5 months ago
the light comes on with all lights when i put the key y in but goes out a few seconds later and stays off when i try cranking i did also check to make sure key sets alarm if i push it it did and i checked to make sure it also locks and unlocks door with both the push buttons and by insertion of the key in the lock
Customer reply replied 5 months ago
What do you think about a bad engine coolant temp sensor? Found a referance as to a similar problem that a bad sensor sending info to pmc had a no spark but was cranking like mine?
Do you happen to have any trouble codes?
Ask Your Own Car Question
Customer reply replied 5 months ago
None on dash
Is it possible to gain access to an actual scanner to do a full scan? It will greatly narrow it down
Ask Your Own Car Question
Customer reply replied 5 months ago
I will see if I can get one
Customer reply replied 5 months ago
none, that i can rent or get with out sending to shop, so before i have it towed off, i replaced the coolest temp sensor no joy any possible ideas with all the items that we have already replaced and checked that could be the issue?
What is the tps voltage reading key on?
Ask Your Own Car Question
Customer reply replied 5 months ago
Key on diconect line checked wires at setting of 20 volts dc reading 0.00 both wires checked with it connected and get 0.01 both wires
Ok let me review the circuit and get back to you at the hospital with the daughter I’ll get back to you tonight when I get back to review the circuit
Ask Your Own Car Question
Customer reply replied 5 months ago
i was on incorrect line the idea valve not tops with the prior reading the tips i got red line 5.0 center blue 0 and outside line red/blue 3.6
Ok it looks like 5volt reference is good but the r d/blue may not be. I’ll check it out when I get near a computer
Ask Your Own Car Question
Customer reply replied 5 months ago
I'm going to order a new one and give a shot should arrive Tuesday
Check the voltage with the connector disconnected. I am not saying that is the issue just a check
Ask Your Own Car Question
Customer reply replied 5 months ago
Got it ,
No problem I checked it connected from back side of plug from grond to low cold line and moved the manual throttle valve control and stil got no voltage on unit

Pink/yellow wire do you get 5 volts?

Ask Your Own Car Question
Customer reply replied 5 months ago
been out working, three wires on unit, a red one on outside a center one blue in color and the last one on the other side of the blue one its a purple in color wire
red outer has 5 volts at the plug disconnect from TPS
blue center has 0 volts at the plug disconnect from TPS
purple outer has 3.6 volt at the plug disconnect from TPSWhen i reconnect the TPS to the wire and check from the back side of the plug with an insert wire i get the following
red outer has 5 volts backside of the plug
blue center has 0 volts backside of the plug
purple outer has 0.67 and a i move throttle all the way open it moves upto 3.6 volt backside of the plug

Seems like the computer is good. Did you check fuel and pulse?

Ask Your Own Car Question
Customer reply replied 5 months ago
I got a fuel psi gage ordered and installed found psi at check port to be 60 psi as for the pulse at the injectors I did check all for power pulse during starting and got it to light on all lines during eng turning, I have rechecked all plugs and coils today during starting and keep getting the same readings the two center plugs fire on a regular timeframe the forward and aft plugs don't fire or at best one time only a have a spare set of new coils and plugs and I tried checking them today once more and they operate the same as the old ones I left I place when testing was complete I swapped out the new cam/crankshaft sensors with the old ones to see if any change with none I replaced them with the new ones and still no difference in operation, after all that was done today I rechecked plugs for firing/pluse and operation same a before forward front plugs fire one time then not again the center plugs fire regularly and the aft plugs got no firing at all?

What about the ground signal of the pulsde of those 2 cylinders, does the ground go away?

Ask Your Own Car Question
Customer reply replied 5 months ago
Checked red wire with node light hooked to pos-post all light up checked to other wire no light hooked up volt meter set at 20 volts dc range getting very low readings during cranking like one volt on the one plug that seams to be sparking
Customer reply replied 5 months ago
It seams that the amount of voltage getting to each coil pack is just to low to produce a firing of spark ecsept at on the two center coil packs and I imagine that's just bearly making it happen, soothing is preventing the correct amount of dc volts from making it to the coil pack? I did get new ASD all so made no difference

I need some live data. a full scan. You may have to take it in unfortunately :(

Ask Your Own Car Question
Customer reply replied 5 months ago
Roger I'm going to see if I can make that happen tomorrow, I will let you know what's up

sounds good :).

Ask Your Own Car Question
Customer reply replied 5 months ago
Had it towed in to local shop the got no codes but said they need eng to run to get live data they want to do a compression check with bleed down and they think that a timing chain could be the issue?
Ok it sounds like the computer disabled the spark for those cylinders for timing reasons? Engine does not need to be running to retrieve live data such as cam/crank correlation.
Ask Your Own Car Question
Customer reply replied 5 months ago
They contacted me with compression check 100 psi on 5 cylinders and 95 psi on 1 cylinder all checked cold they said they then added oil to one cylinder to check it wet and it went up to 175 psi as they stated this is the required psi for this jeep, they did not do a full wet compression check or bleed down check so they think I could be worn out piston rings, they said they would call me back soon, they said as they checked sparks they are getting up to 5 volts on all, when they call me back I will ask what is up with ability to get data with eng just cranking cam/crank position relation and if piston psi could be improved with oil additive like ENG RESTORE and if their data will not show a lock out for cam/crank position relation

Are they saying the spark is good? along with the fuel and pulse?

Make sure they continue checking spark to make sure it does not cut out, sometimes it cuts out after past 4 revolutions.

If spark is good along with pulse and fuel, then cam/crank correlation is fine. It seems they see a mechanical issue of the motor rather then no spark/pulse/fuel.

Keep me up to date on what their results come to be.

Ask Your Own Car Question
Customer reply replied 5 months ago
I will, as when I ran a spark test , I only got the two center Pistons to light the tester so when they call back I will clarify with them did they use a tester that lights on all pistons and if so why even with low compression it is not lighting off as it gets fuel and 100psi is sufficient to start an eng

Exactly, thats the odd part of this, you tested & witnessed no spark. Either you made a mistake in your diagnoses, or they are not telling the truth. Regardless, whatever the issue is still needs to be addressed.

Ask Your Own Car Question
Customer reply replied 5 months ago
Roger

"Thumbs up"

Ask Your Own Car Question
Customer reply replied 4 months ago
Just a heads up on shop looking at my jeep they moved it outside and not done any more with it at this time I will let you know if they get back to me
Ok sounds good
Ask Your Own Car Question
Customer reply replied 4 months ago
Michael,
this is the E-Mail they sent me on my daughter jeep with my reply to the local shop?Thanks much for E-mail I just a few questions prior to taking all info to my daughter for a decision on this repair?
When the mechanic checked the sparks at the coil/spark generating 12 volts did he also check for a spark with a flashing light at each or only use a volt/ ohms meter?
And to check for timing would that be a 4hr charge to check if found replace bad chain / mounting parts replace and reinstall ? as the economics of this will be need for my daughter to make her funding decision. I will check back with you when you all open up next week
Thanks Darrin
From:***@******.*** [mailto***@******.***]
Sent: Friday, December 22, 2017 1:43 PM
To: ***** ***** (DOA) <*****@******.***>
Subject: MIDTOWN KODIAK
Hi Darrin, This is Eric at Midtown Auto. After the time we have spent on all the different checks and verifying low compression, the next step revolves around a few different components. The voltage reference at all the coils is good (all 12v), Coils were replaced as well as spark plugs (after compression test), so they are known good components. You had previously replaced cam and crank sensors, also known good components, and PCM. No codes set during all our attempts to start vehicle, none stored due to new PCM. Timing could be an issue, but does require removing front cover to access timing marks and finding top dead center.The spark issue could be a result of a potential timing issue, and/or different electrical issue which would require further time to track down.
The known low compression issue will continue to be an issue and could require a new engine to complete repair.
We want to be as up front with you as possible knowing a major repair may be needed to resolve completely.
We are into the vehicle for 2 hours at this time, We would need an additional 1-2 hours to chase after spark issues as it pertains to the electrical side, front timing time approaches 4 hours for the purpose of timing verification on the mechanical side, that can be done first or after chasing spark problem.
Please let me know how you would like me to proceed
Thanks, Eric

ok so they are saying there are currently 2 issues going on with the jeep? It does sound like it is going to be a costly repair. I am sorry for the delayed response am currently on vacation and wifi is not working at times

Ask Your Own Car Question
Customer reply replied 4 months ago
All good I have let them complete a timing chain replacement when it arrives hopefully today I will let you know what happens
Darrin

sounds good!

Ask Your Own Car Question
Was this answer helpful?
Ask Michael Solis Your Own Question
Michael Solis
Michael Solis
Michael Solis
Category: Car
Satisfied Customers: 457
457 Satisfied Customers
Experience: Lead Tech at Solis Auto Repair

Michael Solis is online now

A new question is answered every 9 seconds

How JustAnswer works:

  • Ask an ExpertExperts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional AnswerVia email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction GuaranteeRate the answer you receive.

JustAnswer in the News:

Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.

What Customers are Saying:

I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry.

Stephanie PElm City, NC

used your service this weekend with "Trecers" help. thank you ,thank you, thank you. replaced an A/C fan motor. Local Auto Zone had part. $15.00 "tracer" fee and $40.00 for parts, I saved several hundreds of dollers at a shop. i will recommend you and use you in the future.

David L.Richmond, TX

9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much.

PhilMarysville, CA

Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible.

CharlesWalnut Creek, CA

As a single woman, I really appreciate an excellent and affordable opinion.
Thank you Geordie, I will not hesitate to contact justanswer in the future!

SueCharleston, WV

Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, Frank...you do indeed know your stuff.

JimCastleberry, FL

The nearest Volvo dealer is 160 miles away. Best $15 bucks I have spent in a long time!

Paul MCorpus Christi, TX

< Previous | Next >

Meet the Experts:

Chris (aka-Moose)

Chris (aka-Moose)

Technician

1,243 satisfied customers

16 years of experience

Ted G.

Ted G.

ASE Certified Technician

1,724 satisfied customers

20 years auto repair experience, ASE Master Tech, Mechanical Failure consultant, Expert Witness

George H.

George H.

ASE Certified Technician

1,537 satisfied customers

ASE Master Tech 15+ yrs, AAS Automotive Technology, Factory trained Asian specialist

GM Tech (Cam)

GM Tech (Cam)

Auto Service Tech

669 satisfied customers

GM Grand Master Technician 2007. 14 years experience.

Amedee

Amedee

Former ASE Master Tech

2,520 satisfied customers

ASE certified tech advanced level specialist. Wisconsin certified emissions state inspector

Jerry

Jerry

Master Mechanic

2,181 satisfied customers

ASE master, 30+ years. All makes and models. Trouble shooter, shop forman, service manager

Richard

Richard

ASE Certified Technician

1,000 satisfied customers

12 years Ford Lincoln/Mercury Jaguar dealership as a technician and shop foreman reparing all makes

< Previous | Next >

Related Car Questions
I jumped my car backwards (I was verrry tired). As the other
Hi. I jumped my car backwards (I was verrry tired). As the other set of the cables were put on the other car, there was a spark, pop, and my alarm went off. From there, I had no spark and the car woul… read more
eric remington
eric remington
FORMER SHOP OWNER/TECHNICIAN/INSPECTOR
associates degree
554 satisfied customers
2003 murano engine vibrates while idling in gear. Problem
2003 murano engine vibrates while idling in gear. Problem started when I ran over curb getting out of parking space. RPMS dropped to 500. Car immediately started to vibrate. Replaced all of motor and … read more
Jake
Jake
308 satisfied customers
I have a 2009 Jeep wrangler that has the “death wobble”. I
I have a 2009 Jeep wrangler that has the “death wobble”. I had something like the axel welded to something. And it worked for a while. Then they put a damper on the steering column. Didn't work. I rea… read more
indy-tech
indy-tech
Shop owner, technician
Vocational, Technical or Trade Scho
11 satisfied customers
I have a 1996 Ford Aspire. My mechanic says I have a leak in
I have a 1996 Ford Aspire. My mechanic says I have a leak in my rack and pinion and need to replace it for $900. I don't have power steering! How can my rack and pinion leak? … read more
HDGENE
HDGENE
Master Technician/Lead Technician
Associate Degree
2,835 satisfied customers
Recently had head gasket replaced. Now clock starts at 12:00
recently had head gasket replaced. Now clock starts at 12:00 daily and the starter cranks slowly. I cleaned the ground on the engine block. … read more
Danny
Danny
Owner, lead mechanic
High School or GED
3,963 satisfied customers
Slider pins not sliding. how do I remove and lubricate. I
slider pins not sliding. how do I remove and lubricate. … read more
David Craig
David Craig
OWNER/MECHANIC
Associates
5,253 satisfied customers
Bentley Supersport Windows Wont go up. 2017. I had two
I had two mechanics here tell me that the regulator needs to be reset … read more
Danny
Danny
Owner, lead mechanic
High School or GED
3,963 satisfied customers
The warning light on my 2013 Altima says" MAintenance -
The warning light on my 2013 Altima says " MAintenance - Tire" but the tires are inflated properly. What to do? … read more
jim
jim
Vocational, Technical or Trade Scho
702 satisfied customers
I own a GLE coupe 2016, and a month ago my mechanic replaced
I own a GLE coupe 2016, and a month ago my mechanic replaced the right front strut and the sway bar because it was making a noise, after breaking a wheel hitting a big road hole, but, inmediately afte… read more
Danny
Danny
Owner, lead mechanic
High School or GED
3,963 satisfied customers
I was driving about less then 10 miles an hour and my 08 G6
I was driving about less then 10 miles an hour and my 08 G6 drove straight into water about to the end of the door, I pushed the car off to the side and tried Turning it on about 5 hours later and it'… read more
Edward Clayton
Edward Clayton
Associate Degree
1,033 satisfied customers
I have a 2006 fusion 2.3L, my code reader indicts that the
I have a 2006 fusion 2.3L, my code reader indicts that the intake manifold runner control stuck open bank 1, I've replaced both control modules but had little effect … read more
indy-tech
indy-tech
Shop owner, technician
Vocational, Technical or Trade Scho
11 satisfied customers
I was talking with a mechanic and got cut off. 2007 Honda
I was talking with a mechanic and got cut off. JA: What is the model/year of your Honda? Customer: 2007 Honda Fit JA: Are you fixing your Fit yourself? What have you tried so far? Customer: No JA: Any… read more
Kevin
Kevin
workshop foreman /master tech/mot tester
1 satisfied customers
Kind of in a situation here. My wife is 150 miles away with
Hello kind of in a situation here. My wife is 150 miles away with a horse trailer and horses. The 2015 Chevy Duramax is giving her alerts to Service the emissions system and it is speed limited. Befor… read more
Danny
Danny
Owner, lead mechanic
High School or GED
3,963 satisfied customers
Radio/nav display went dead and won't come back. this was 2
radio/nav display went dead and won't come back. this was 2 days ago. … read more
Danny
Danny
Owner, lead mechanic
High School or GED
3,963 satisfied customers
Hyundai sonata 2010 noticed this broken on car what is it?
Hyundai sonata 2010 noticed this broken on car what is it? Some kind of connection will add a picture its right of the altanator center valve has nothing connected to it and appears broken… read more
Kevin
Kevin
workshop foreman /master tech/mot tester
1 satisfied customers
I have a 2007 HONDA FIT the D on the dash is flashing. I
I have a 2007 HONDA FIT the D on the dash is flashing. I hooked up an OBDII sensor and it says code UO121 FCAN malfunction. I changed the transmission pressure switch down by the bottof the dipstick, … read more
David Craig
David Craig
OWNER/MECHANIC
Associates
5,253 satisfied customers
Replacing the water pump on a 2000 E320. Parts came with 2
Replacing the water pump on a 2000 E320. Parts came with 2 gaskets - one is thin rubber and fits inside the housing of the water pump - the other is plastic and aligns with the holes of the water pump… read more
David Craig
David Craig
OWNER/MECHANIC
Associates
5,253 satisfied customers
Warnning light filter is at risk of clogging. On the
warnning light filter is at risk of clogging JA: Just to clarify, what are the exact lights you're talking about? Customer: on the dashboard yellow triangle JA: What is the model/year of your Peugeot?… read more
Kevin
Kevin
workshop foreman /master tech/mot tester
1 satisfied customers
Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Show MoreShow Less

Ask Your Question

x