How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Solis Your Own Question
Michael Solis
Michael Solis,
Category: Car
Satisfied Customers: 170
Experience:  Lead Tech at Solis Auto Repair
99786211
Type Your Car Question Here...
Michael Solis is online now
A new question is answered every 9 seconds

Changed the crankshaft position sensor on my 2005 2.4ltr pt

This answer was rated:

Changed the crankshaft position sensor on my 2005 2.4ltr pt cruiser(OBD failure indication after incidental misfire during accelleration).For 2 weeks no problems,now same thing re-occurring.OBD read-out now indicates sensor circuit( P0340 in stead of P0335) malfunction.Any ideas?
JA: Does the vehicle stall at low speeds? Does it sputter?
Customer: Not at all!
JA: What is the model of your '05 Chrysler?
Customer: 2.4ltr Limited
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: Renewed the crankshaft position sensor
JA: Anything else you want the mechanic to know before I connect you?
Customer: No

Hello, my name is ***** ***** I will be assisting you today. The p0340 code is an idication of a cam sensor/timing belt problem. It does not stall? It starts right up? no loss of power? here is a procedure for that code

1. Check the Camshaft Position (CMP) sensor for 5 volts on the Orange wire.

2. Check for 5 volts on the Tan/Yellow wire with it unplugged from the sensor.

3. Jumper the Tan/Yellow wire to the Black/Light Blue wire to see if the 5 volts is pulled to ground indicating a good sensor ground.

4. Scope the signal wire. There should be a 0-5 volt square wave. If not, either the CMP sensor is bad or the timing belt is broken

If you have any questions let me know.

Customer: replied 1 month ago.
Engine does not stall,it starts right up and there is no loss of power.
Problem is occasional misfire whilst driving and then the warning light comes up.

Cam sensor could very well be bad then on occasion the ignition coil could cause that, but it is looking closer to the cam sensor being the problem

Customer: replied 1 month ago.
Thanks.I will check the wiring of the CMP and letyou know.

no problem!

It was my pleasure answering your question. Now that we have either answered, or somewhat answered the question, I will offer my rating. Please let me know if for some reason you are not satisfied with the results I gave you, let me know because I strive for excellence & a 5 star. If you feel 5 star is not worth it, let me know what else I can do or change. Leaving a bad rating or negative rating only hurts me not the site. So please let me know if there is something I can do for you to earn your 5 star rating. Thank you. Sincerely, Michael.

It was my pleasure answering your queson. Now that we have either answered, or somewhatanswered the queson, I will oer my rang. Please let me know if for some reason you are notsas'ed with the results I gave you, let me know because I strive for excellence & expect a 5 star.If you feel 5 star is not worth it, let me know what else I can do or change. Leaving a bad rangor negave rang only hurts me not the site. So please let me know if there is something I cando for you to earn your 5 star rang. Thank you. Sincerely, ***** ***** my pleasure answering your queson. Now that we have either answered, or somewhatanswered the queson, I will oer my rang. Please let me know if for some reason you are notsas'ed with the results I gave you, let me know because I strive for excellence & expect a 5 star.If you feel 5 star is not worth it, let me know what else I can do or change. Leaving a bad rangor negave rang only hurts me not the site. So please let me know if there is something I cando for you to earn your 5 star rang. Thank you. Sincerely, Michael.

It was my pleasure answering your question. Now that we have either answered, or somewhat answered the question, I will offer my rating. Please let me know if for some reason you are not satisfied with the results I gave you, let me know because I strive for excellence & a 5 star. If you feel 5 star is not worth it, let me know what else I can do or change. Leaving a bad rating or negative rating only hurts me not the site. So please let me know if there is something I can do for you to earn your 5 star rating. Thank you. Sincerely, Michael.

Customer: replied 1 month ago.
Michael,Checked the wiring.OK.Just fitted a new camshaft sensor and drove approx. 50 miles,alternating town and highway.
Car runs fine Problem solved.Many thanks for the excellent service.
Kind regards,
Jan
No problem glad it's fixed! Please don't forget to rate.
Michael Solis and other Car Specialists are ready to help you