How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jaybird61 Your Own Question
Jaybird61
Jaybird61, ASE Certified Master Technician
Category: Car
Satisfied Customers: 1708
Experience:  Automotive Instructor at Palm Beach State College
93113249
Type Your Car Question Here...
Jaybird61 is online now
A new question is answered every 9 seconds

One of my car radiator fan doesn't work only one works but

This answer was rated:

One of my car radiator fan doesn't work only one works but when I turn on the ac they both work, what's my problem?
JA: Has the car been overheating? Have you checked the fuses?
Customer: It overheats yes & all the fuses are good even the car sensor is good too
JA: What is the model/year of your Kia?
Customer: 2003 Kia Optima
JA: Are you fixing your Optima yourself? What have you tried so far?
Customer: My father is a mechanic but he can't seem to see why one of the fans isn't working
JA: Anything else you want the mechanic to know before I connect you?
Customer: That's all

Hi, My name is Jay

One fan is for the engine and has two speeds. The other fan only comes on with the a/c. When does it overheat and how quick after it starts does it overheat?

What engine do you have? The 4 or 6 cylinder?

Customer: replied 2 months ago.
It's a 2.4 the engine and 30 mins max it's overheated
Customer: replied 2 months ago.
when you turn on the AC it starts to overheat

Has anything been changed to try and fix the problem yet? Like the thermostat?

Here is the wire diagram so your father can see if the system fans are going into low and high speed and can check the low and high speed fan relays.

https://www.dropbox.com/s/ok48fgdbpprnwny/2003%20kia%20optima%20ac%20system.pdf?dl=0

Customer: replied 2 months ago.
We changed water pump, Sensor , different fan thats what we changed

Did you put in a thermostat?

Customer: replied 2 months ago.
We used the one from the old engine we had in it

Try to replace it with a new one and replace the high speed relays in the diagram I gave you and see what happens. I would not recommend using a used thermostat from another motor that may have been bad already.

Customer: replied 2 months ago.
Okay is that it

Since you put a used engine in you have to start somewhere.

"I hope that helps! My goal is your satisfaction today. If you feel I've been professional and helpful, your 5-star rating at this time is most appreciated. However, if you still need my help reply back here -- I'll respond as soon as possible! Thank you"

Jaybird61 and 11 other Car Specialists are ready to help you