How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Car
Satisfied Customers: 22985
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Car Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Bought my E320 d auto on Tuesday. Lovely car and drove the

This answer was rated:

Hello, Bought my E320 d auto on Tuesday. Lovely car and drove the 50 miles home with no problems. Only done a few miles more in the last few days and went out this morning to local shops and the cars engine was revving but not really going anywhere, really limping!! Parked up for half hour, shopped and then drove home with no real problems at all!! Any clues please? Many thanks, Ray
JA: How many miles are on the car? Is it an automatic or a manual transmission?
Customer: Auto Paul 92k avengard
JA: What year is your E320?
Customer: 04
JA: Are you fixing your E320 yourself? What have you tried so far?
Customer: This has only just happened and to be honest, don't really know where to start!?
JA: What confuses you?
Customer: Went into the muti storey to go shopping and like I said, the cars revs increased as normal but the car just wasn't pulling away much! Really sluggish almost like the clutch slipping!! So don't really know if it's a gearbox or clutch fault!! When I came back to the car after about an hour, it drove home fine!! Really confused😳
JA: What confuses you?
Customer: Why the car has suddenly gone into limp mode and then after re start all is fine!!
JA: Anything else you want the mechanic to know before I connect you?
Customer: No, think that's it thanks Paul

Hello and welcome to JustAnswer!

If it was still pulling to some extent but RPM's were high and it didn't want to move then the transmission was slipping. It could be due to clutch or hydraulic failure but it may also have been due to a restricted filter. If the filter becomes restricted with debris from lack of periodic maintenance then it can cause enough line pressure drop for the trans to disengage.

The first thing that will need to be done is see what fault codes have set. From there the next step will most likely be to pull the pan for inspection. It's possible that the trans will need to be overhauled or replaced, but it's possible that you may be able to at least buy some time with a filter replacement.

I hope that helps! My goal is your satisfaction today. If you feel I've been professional and helpful, your 5-star rating at this time is most appreciated. However, if you still need my help you can reply back here and I'll respond as soon as possible! Thank you!

sprinkles08 and other Car Specialists are ready to help you