How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 1176
Experience:  16 years of experience
2499435
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

2007 equinox 3.4l, high RPMs after throttle body

Customer Question

2007 equinox 3.4l, high RPMs after throttle body replacement. Runs about 3000RPMS, no vacum leaks and no DTC
Submitted: 2 months ago.
Category: Car
Expert:  TECHPRO49 replied 2 months ago.

Hello my name is ***** ***** I will be assisting you with all of your vehicle questions today. Give me one moment while I review your question and come back with a answer. Please be aware I do not know your skill level or abilities so I will be asking a lot of questions and in a lot of cases we will respond to each other quite a lot before we find a solution. As far as phone calls are concerned that is the system prompting you, not me, and they do cost more money, I prefer text but in some cases a phone call is required.

Have you tried disconnecting the battery and touching the cables together?

Customer: replied 2 months ago.
tried driving above 44 and then quick deceleration as well. I have not had the new TB relearned would that be necessary or is it just plug and play.
Customer: replied 2 months ago.
I did a check for vacuum leaks could not find anything. All electrical hook ups are clean and in place as well.
Expert:  TECHPRO49 replied 2 months ago.

it needs to be relearned, I was trying to see if we could do that with out going for the relearn, so try this, do the cable thing crank it up let it ilde for 10 mins, turn on all accessories, everything, wait another 10 mins, then put it in drive and also with everything on and wait another 10, turn of wait 5 mins and restart, this may relearn the the t/b

Customer: replied 2 months ago.
Thanks I will go forth and conquer, and let you know.
Expert:  TECHPRO49 replied 2 months ago.

haha no problem, god speed sir!