How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FixItMan Your Own Question
FixItMan
FixItMan, Master Technician
Category: Car
Satisfied Customers: 17479
Experience:  AA DEGREE AUTOMOTIVE/DIESEL TECH
1627031
Type Your Car Question Here...
FixItMan is online now
A new question is answered every 9 seconds

I've had my alternator and water pump replaced in my 98

Customer Question

I've had my alternator and water pump replaced in my 98 Tercel. I also had both belts replaced. The belt started squeaking again, so I assumed it was maybe something with the power steering pump. Well, i pulled that belt out and it still squeaks. So, it
looks like it's the water pump/alternator belt. I'm not sure what might be causing it. maybe, something leaked onto the belt and affected it? maybe, it's the pulleys? Any thoughts on what it might be. The belt tension seems fine. I hate pulling that belt out
because it's a headache. I could pull it out, and spin the water pump and alternator pulleys, and if they seems smooth, maybe, it's just something with the belt. The belt screeches on startup.... it let it warm up for a bit, and it will stop. It may squeal
on the first few turns, or when accelerating, but eventually, it will stop, until the next startup. However..... yesterday, we had our first rain in a long time, and it was raining all day, and the belt was horrible.... it was pretty much squealing at ever
stop/light, until I would get up to speed again. I'm wondering if you have suggestions, or thoughts on what might be causing the belt sound.
Submitted: 2 years ago.
Category: Car
Expert:  FixItMan replied 2 years ago.
Hello, my name is Bobby. Thank you for the question. If the problem was not there prior to replacing these parts then you may have a defective alternator or belt. It is common for the alternator pulley to just be slightly off and cause this. Look closely to see if it signs up with the other pulleys. You also need to replace the belt if it did get contamination on it as any oil or petroleum product on the belt will cause this. Let me know if you need more help.