How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask nabilc Your Own Question
nabilc
nabilc,
Category: Car
Satisfied Customers: 3498
Experience:  Manager/co-owner at Autotronic
30385560
Type Your Car Question Here...
nabilc is online now
A new question is answered every 9 seconds

Yeh mate ER 55 on dash with abs light, malfunction light and

Customer Question

Yeh mate ER 55 on dash with abs light, malfunction light and cruise light flashes on and off while this happens the abs doesn't work and it doesn't rev past 5000 revs the car is a 3.0 rb wagon 6 speed the cruise won't work either while this all happens and only started since wheel bearing has been replaced has anyone else had this problem any ideas any feedback would be much appreciated thanx ?????
Submitted: 5 years ago.
Category: Car
Expert:  nabilc replied 5 years ago.

Billy :

Hello and Welcome! I'm Billy and i will assist you with your inquiry. Feel free to ask if any further info is needed.

Billy :

Since the wheel bearing was replaced, the thing that would affect all these warning lights and is related would be the ABS wheel speed sensor.

Billy :

The sensor can be viewed easily once the wheel is removed, and so the toothed ring on which the sensor reads.

Billy :

You will need to chech first the sensor itself, see if it is fitted correctly (or loose etc...), and then check the wiring, if disconnected or even loose.

Billy :

Then you will need to check if the toothed ring is in place (this also needs to be clean). Having made sure that these are installed correctly, and if the problem persists, then you need to reset the fault using a subaru scan tool.

Billy :

Again, many other errors would cause these symptoms (warning lights and cruise and ABS not functionning), but having this just after the bearing replacement, the sensor and toothed ring (being not properly installed) would be the most likely reason.

Billy :


Thank you for your trust! Get back to me if you need more info..if not, Thank you in advance for the positive rating...
http://www.justanswer.com/car/expert-billy/
And do not forget to check out the other categories (health, law, taxes, vet, etc...)