How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 1176
Experience:  16 years of experience
2499435
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

MY SPEEDO IS READING INTERMITENTLY ,FROM ZERO..LR..TRANSPONDER

Customer Question

I HAVE A 2.8I 110 MODEL 1999 , MY SPEEDO IS READING INTERMITENTLY ,FROM ZERO TO ACTUAL SPEED THEN STOPS READING FOR 15MINUTES AND STARTS AGAIN ,IT DOES NOT MATTER WHAT TERRAIN I DRIVE ON LR SA HAS REPLACED THE TRANSPONDER TWICE AND HAVE NOW GIVEN UP. I HAVE 130,000KLM ON THE CLOCK ,ANY SUGGESTIONS
Submitted: 6 years ago.
Category: Car
Expert:  Tom replied 6 years ago.
So the speed sensor has been replaced?
Customer: replied 6 years ago.
yes three times
Expert:  Tom replied 6 years ago.
Ok has the communication mine been checked along with the actual gauge
Customer: replied 6 years ago.
three years ago new speedo fitted, current one line checked diagnostics showed a problem but on retest it went away they keep replaceing the transducer[lybe100540],
but after replaceing it only worked for one to two days then back to intermittent working
over corrigations it works then does not , on asphalt it also works as it wants to.
Expert:  Tom replied 6 years ago.
Sounds like a connection issue or communication issue . These need to be checked .