How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Your Auto Inspector Your Own Question
Your Auto Inspector
Your Auto Inspector, Assistant Service Manager
Category: Car
Satisfied Customers: 874
Experience:  Tires Plus
10675526
Type Your Car Question Here...
Your Auto Inspector is online now
A new question is answered every 9 seconds

I HAVE A 1997 MAZDA MILLENIA.V6 CODE P1402 I CHECKED THE EGR

This answer was rated:

I HAVE A 1997 MAZDA MILLENIA.V6 CODE P1402 I CHECKED THE EGR VALVE WORKING WITH VACUUM AND IT IS NOT OPENING WHEN YOU THROTTLE UP THE ENGINE. I CHECKED THE VACUUM RELAY, NOT OPENING TO LET ENOUGH VACUUM TO OPEN EGR VALVE, NOT SURE WHAT TELLS THE RELAY TO OPEN AND CLOSE VACUUM TO EGR. THE RELAY WORKS WHEN I CHECKED IT WITH VOLTAGE AND VACUUM. OPENS WHEN VOLTAGE APPLIED. ANY HELP WOULD BE APPRECIATED.?

Sounds like a failing EGR valve position sensor. Here is the diagnostic process for your code:

 

graphic

 

Heres a diagram of the EGR valve position sensor location:

 

graphic

 

Sensor Inspection

  1. Disconnect the EGR valve position sensor connector.
  2. Disconnect the vacuum hose from the EGR valve and connect the vacuum pump to the EGR valve.

graphic

Use an Ohmmeter to measure the resistance between the terminals as shown in the table.

graphic

 

It not as specified, replace the EGR valve.

 

Please let me know if there is anything else I can do to assist you.

Customer: replied 8 years ago.
drhorsefield,


   ichecked the ohms and all checked out except the b-c posts. it gave 2.4 with out vacuum, but i put vacuum to it and no change. stayed at 2.4 , does that mean if one is off the whole unit needs to be replaced? i would appreciate any input. thanks darin

Yes, if any of the readings are incorrect you will have to replace the unit.

 

Please let me know if there is anything else I can do to assist you.

Customer: replied 8 years ago.
drhorsefield.


sorry it took ss long to get back to you, i have been waiting for the egr valve to arrive. it has come and i still am getting the code 1402.. any suggestions..? the light comes on after a while when it gets hot. probably with in 10-15 minutes/
    thanks for your patience and cooperation on helping me get this settled.

                      darin

You need to check the harness. Here is the test procedure:

 

  • Disconnect the vacuum hose from the EGR valve and connect the vacuum pump to the EGR valve.
  • Turn the ignition switch to ON.
  • Measure the voltage at the terminals as shown in the table.
  •  

    graphic

  • If not as specified, inspect the harness between EGR valve position sensor and PCM.
  •  

     

    Also double check the readings from the PCM. Here is the PCM connector diagram so you can check the terminals in the diagnostic process that I previously posted:

     

    graphic

    graphic

    graphic

    graphic

    graphic

    graphic

     

     

    Your Auto Inspector and 5 other Car Specialists are ready to help you
    Customer: replied 8 years ago.


    I CHECKED THE VOLTAGE AND IT ALL CHECKS OUT JUST AS THE DIAGRAHM SAYS. I'M GETTING A CODE 1195 AND 0300 NOW ALS0, THIS ISN'T MY CAR BUT I WAS ASKED TO FIX IT , IT HAS ALL NEW WIRES PLUGS AND CAP AND ROTOR, NOT SURE WHY THIS IS HAPPENING? ANY IDEAS? THANKS

                                DARIN
    Customer: replied 8 years ago.


    drhorsfield,



       I will accept this payment to you , and do appreciate all the help so far, but the light still stayed off for a while but is now back on, no sure what else to check since i am a diy usually in the evenings, so i would appreciate any other info on this car. thanks for your help this far.