How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask stereoaz Your Own Question
stereoaz
stereoaz, Car Electronics Technician
Category: Car Electronics
Satisfied Customers: 113
Experience:  35 years in car audio,my shop won iasca world title ,custom fabrication,expert installer.
45259138
Type Your Car Electronics Question Here...
stereoaz is online now
A new question is answered every 9 seconds

I have a sound stream 10.3 VR-103B radio in my truck and the

Customer Question

I have a sound stream 10.3 VR-103B radio in my truck and the screen has recently stopped working. The eject button still works. I press that and it'll lift up and all so I know it's getting power. Just want to see if you had any ideas to try before I throw it away.
JA: What's the make/model of your device? How old is it?
Customer: Would that be displayed on the device? The radio was already in the vehicle when I bought it but the original owners say it's not even a year old.
JA: How long has this been going on? What troubleshooting have you tried?
Customer: For about two weeks
JA: Anything else you want the electronics expert to know before I connect you?
Customer: I checked fuses in the truck and looked for loose connections behind the radio and everything looks fine.
Submitted: 3 months ago.
Category: Car Electronics
Expert:  Louie replied 3 months ago.

Hi and welcome to JustAnswer, I’m Louie. Sorry you had to wait awhile but I’ll do my best to help.

Initially, is a volt/multi-meter available?

Customer: replied 3 months ago.
Customer: replied 3 months ago.
I have a fluke DMM
Expert:  Louie replied 3 months ago.

Still, let's try and review the basics. Proposed preliminary checks (if have not been done and even if just to eliminate as suspects):

  • • always available BAT+12V on the yellow wire;
  • • switched ACC+12V on the red wire;
  • • and ensure that the black wire is attached to vehicle's body ground and not only to the harness ground line.

Please post back results / observations of the above once tried.

All others would be internal to the VR-103B.

Customer: replied 3 months ago.
Everything is good!
Expert:  Louie replied 3 months ago.

I understand

And that would be indicative of an internal hardware issue.

Are you then considering a DIY (do-it-yourself) repair approach? If yes, do you have access to and familiar with a multi-meter (and even perhaps a soldering iron)?

Customer: replied 3 months ago.
I had the iron. I need to go buy more solder wire though.
Customer: replied 3 months ago.
I'll crack it open and see what I can find. No big deal if I have to toss it. Was really just trying to see if this was a common issue with this model and if it was an easy fix or not.
Expert:  Louie replied 3 months ago.

Past/known issues would be the flex cable breaking and in some others the display itself (backlighting) failure.

Still, let's start with visual inspection.

Please post back clear pictures once opened. Click HERE.