How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie
Louie, Car Electronics Technician
Category: Car Electronics
Satisfied Customers: 12460
Experience:  25+ yrs. experience in the field and 5+ yrs. online, down to component level.
13948492
Type Your Car Electronics Question Here...
Louie is online now
A new question is answered every 9 seconds

I have a sx 580 pioneer amp (over 30 years old) has worked

Customer Question

I have a sx 580 pioneer amp (over 30 years old) has worked fine,. I just changed location & was hooking everything up & now I lose sound after about 5 seconds. Same if its set to FM, AM, or AUX for CDs. Power stays on, sound comes on for a few seconds then no sound. If I turn it off & back on on , it has sound again for a few seconds, yjem gone
Submitted: 1 year ago.
Category: Car Electronics
Expert:  Louie replied 1 year ago.

Hi and welcome to JustAnswer,

Thank you for the question and your patience. Should you still need assistance for information purposes only...

Initially, the only easy user doable tried would be to gently tap and exercise the different controls and switches. Or better yet, consider using compressed air or better yet, plastic safe / non-staining DeoxIT DN5 or LPS 03116 Contact Cleaner or equivalent to clean the insides of these controls and switches. Include the headphone jack as there is a built-in speaker cut-off switch.

All others would point to an internal hardware issue .