How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Reggie Whiddon Your Own Question
Reggie Whiddon
Reggie Whiddon,
Category: Cadillac
Satisfied Customers: 162
Experience:  Lead tech at river regions auto
90546729
Type Your Cadillac Question Here...
Reggie Whiddon is online now
A new question is answered every 9 seconds

Idles just gone in park drive and reverse skip, And rough

Customer Question

Idles just gone in park drive and reverse skip
JA: How many miles are on the car? What size is the engine?
Customer: And rough idle
JA: What is the model/year of your Cadillac?
Customer: 151,331 and northstar v8 2002 deville dts
JA: Are you fixing your DeVille yourself? What have you tried so far?
Customer: I know it was leaking coolant around the coolant reservoir so I put some jb weld putty around it to hold it for now haven't had that problem and gas treatment and fuel injection cleaner cause the previous owner saaaaid it was sitting up a little bit I just got it today
JA: Anything else you want the mechanic to know before I connect you?
Customer: That's all I know about it right now
Submitted: 4 months ago.
Category: Cadillac
Expert:  Reggie Whiddon replied 4 months ago.

Hi im Reggie thanks for using JustAnswer. Put my years of experience and training to work for you

Expert:  Reggie Whiddon replied 4 months ago.

Hello and thanks for giving me the opportunity to help you, ahh the northstar, sometimes i see these in my sleep we have a couple funeral homes and a limo company and i think every one of there limos and hearses are Cadillac chassis. So lets dig right in , you say you put some jb weld on the coolant reservoir was that a crack in the tank? That may be a good patch but that reservoir has got to go. ONe thing if you dont know about these cars is they run to damm hot to start with from the factory the coolant fan does not come on to around 210 215, And the system is rated at 16 psi and it operates under 10 12 psi normally. This is what we have, did you notice i said the fan will not come on to 212? the problem is that is the boiling point of water. Water boils at 212 but put it in a 10psi pressure it goes to 240 15 psi it goes to 250 understanding that you can see why maintaining a properly sealed system is critical. I have put engine after engine in because the owner or there mechanic did not understand the cooling system on these cars. And you may already know by design they have a head sealing problem that is really only corrected by installation of steel thread inserts in block.

Now if i read right your main complaint is the car is skipping in drive and reverse, is that right? Is it running hot at all? Is it losing coolant? And finally does it smooth out above idle in other words once you get it going does it run good? Or do we have a constant dead skip? Do you smell or see anything unusual out exhaust? Is your check engine light on? Can you get a code reader and check for codes and retrieve the misfire data it will have current and history misfires for each cylinder. I want to help you and can but im going to need more information, codes, data in particular misfire for cylinder, short and long term fuel trims, Mass Air flow in gm/s get a reading at idle and then snap the throttle wide open and record highest reading, MAP sensor, coolant and intake air temperature. I look forward to hearing from you.