How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Cadillac Technician
Category: Cadillac
Satisfied Customers: 26646
Experience:  ASE certified Technician advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Cadillac Question Here...
Amedee is online now
A new question is answered every 9 seconds

My 92 cadillac deville 4.9 it idles ok when you put in drive

Customer Question

My 92 cadillac deville 4.9 it idles ok when you put in drive and accelerate it boggs down get of gas and drive normal it ok and then when you give it more gas it will not accelerate i have done a complete tuneup and changed the whole distributor and fuel pump and filter but it still does it can you help
JA: Have you ever replaced the fuel pump, or is this the original?
Customer: New fuel pump and filter
JA: Are you fixing your DeVille yourself? What have you tried so far?
Customer: Complete tuneup, fuel pump and fuel filter and new distributor
JA: Anything else you want the mechanic to know before I connect you?
Customer: Im at whitts end
Submitted: 7 months ago.
Category: Cadillac
Expert:  Amedee replied 7 months ago.

Hello and welcome!

My name isCustomerand I can assist you with your question.

Expert:  Amedee replied 7 months ago.

I will try my best to answer all of your questions.

However, before we get started, please let me mention a few things.

1. If at any point you would like to speak on the phone, please feel free to request a phone call on your end and I can call you right away.

2. If you dont understand any technical terms or anything that I mention (component tests or theory or operation), please let me know and I will provide you with a more in debt explanation or answer.

3. Please understand that I am here to help you anyway I can.

Expert:  Amedee replied 7 months ago.

Are you looking for possible causes or would you like me to walk you through this diagnoses?

Have you checked for codes in the computer?

Customer: replied 7 months ago.

Do not have any, no lights on

Expert:  Amedee replied 7 months ago.

Hello and thank you for that information.

Based on my experience, the two most common causes for this condition are low fuel pressure and plulgged exhaust. You said the fuel pump and filter were replaced? If so, what is the fuel pressure at under a load?

Also, what is the engine vacuum at or exhaust back pressure readings at?

Another possible cause would be fuel injectors. The fuel injectors could be bad or they may not be opening up enough to allow enough fuel into the engine. This would be based on a computer input. For example, the MAP sensor or TPS could be bad. I would check both sensors and signals at idle and under a load.