How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Cadillac Technician
Category: Cadillac
Satisfied Customers: 28744
Experience:  17 years Cadillac experience as a technician.
14928985
Type Your Cadillac Question Here...
Pete is online now
A new question is answered every 9 seconds

I was going down the road went into high idle pulled off put

Customer Question

I was going down the road went into high idle pulled off put car in neutral idling high rpms, Put on brake put in park Shut engine off went to restart no power whats so ever except door locks worked no dash lights interier lights. What could have blown
JA: Is the power loss consistent, or does it fluctuate?
Customer: no power
JA: What is the model/year of your Cadillac?
Customer: iing on side of road
JA: What year is your Cadillac?
Customer: 1996
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: going to try checked fuses all ok. Tried shifting several times nothing comes on when key is turned
JA: Anything else you want the mechanic to know before I connect you?
Customer: security went out last year would not start fixed supposedly at AAA service garage
Submitted: 10 months ago.
Category: Cadillac
Expert:  Pete replied 10 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Have you checked to see if your battery is o.k.?

Let me know so we can continue,thanks Pete

Customer: replied 10 months ago.
Customer: replied 10 months ago.
the battery is ok
Customer: replied 10 months ago.
Pete you still there
Expert:  Pete replied 10 months ago.

I am here just looking over some info now.

Expert:  Pete replied 10 months ago.

What model Cadillac is this vehicle here?

Customer: replied 10 months ago.
1996 sedan deville its two miles away
Expert:  Pete replied 10 months ago.

O.k.,it looks like your battery has 3 connections in one cable that connects to the positive post at the battery.Check and see first if there is any corrosion or damage or looseness to this cable connection.I have seen this before with corrosion or looseness cause this fault.If this is or was checked and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 10 months ago.
ok ill check that and can i get back to you without additional charge
Expert:  Pete replied 10 months ago.

You can come back here at any time and respond to this post here when ready.

Thanks Pete