How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, Buick Technician
Category: Buick
Satisfied Customers: 17146
Experience:  15 years master GM tech and mater ASE tech
19513769
Type Your Buick Question Here...
Gary is online now
A new question is answered every 9 seconds

2010 Buick Lucerne-- getting 'Engine HOT, A/C OFF displayed

This answer was rated:

2010 Buick Lucerne-- getting 'Engine HOT, A/C OFF displayed but even on cold start. Where is the BCM Module located so I can check connector fittings?
JA: Have you checked the Freon level?
Customer: No - even if I do not try to turn AC on. This is intermittent error display and when it is shown, there is also zero reading on temp gauge. But engine running normal temp.
JA: Are you fixing your Lucerne yourself? What have you tried so far?
Customer: Some online reports say thermostat might cause, others say BCM module. I would try to fix self if only change in thermostat or checking for good continuity at BCM connector... where is this module physically located?
JA: Anything else you want the mechanic to know before I connect you?
Customer: No - there is a ton of reports online for this issue... I'm convinced the engine is running normal, it's just getting wrong sensor reading or something and computer is intermittently killing ability to read temp gauge or selecting AC power on

Welcome! My name is ***** ***** I will do my best to assist you with this problem.

i agree with you

this should not be a BCM issue

the issue is usually caused by the engine coolant temp sensor or the connector at the coolant temp sensor

what usually fixes this is a new engine coolant temp sensor and a new temp sensor connector

basically the coolant temp reads wrong and causes all these issues you are having

please dont forget to rate me here at Justanswer

you can always get me back for FREE for any follow up any time with this question even after you rate me here at Justanswer

if you have any questions please ask as i do not get credit for my work until you rate me here at Justanswer

Gary and 3 other Buick Specialists are ready to help you