How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Buick
Satisfied Customers: 24468
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Buick Question Here...
Dan is online now
A new question is answered every 9 seconds

1999 BUICK CENTURY CUSTOM 3.1 L ENGINE STALLS AFTER RUNNING

Customer Question

1999 BUICK CENTURY CUSTOM 3.1 L ENGINE STALLS AFTER RUNNING FOR 5 TO 10 MINUTES AND WILL NOT RESTART WITHOUT SETTING FOR 10 MINUTES...COMPUTER DEFECT CODE P0446
JA: Is the check engine light on? Does the car stall at idle or when driving?
Customer: STALL AT IDLE OR WHILE DRIVING...CHECK ENGINE LIGHT IS ON FOR ONLY DEFECT CODE P0446
JA: Are you hoping to fix this yourself?
Customer: YES
JA: Great! What have you tried so far?
Customer: TWO IGNITION COILS...CRANKSHAFT POSITION SENSOR...CAMSHAFT POSITION SENSOR...FUEL PUMP RELAY
JA: Is there anything else the Buick Mechanic should be aware of about your Buick?
Customer: FUEL PRESSURE IS IN PROPER RANGE EVEN WHEN ENGINE STALLS OUT...THERE IS NO ROUGH IDLE...JUST AS THOUGH RAN OUT OF GAS
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Buick Mechanic about your situation and then connect you two.
Submitted: 1 year ago.
Category: Buick
Expert:  Dan replied 1 year ago.

Hello, my name is***** you checked for spark during no start?

Customer: replied 1 year ago.
THERE IS SPARK...
Expert:  Dan replied 1 year ago.

Have you tried to see if it will run on starting fluid during no start? Or tried to see if it will run with mass airflow sensor disconnected?

Customer: replied 1 year ago.
CLEANED MASS AIR FLOW SENSOR...BUT NOT TRIED STARTING FLUID DURING NO START
Expert:  Dan replied 1 year ago.

Try to see if starting fluid gets it running during no start and if unplugging mass airflow sensor allows it to start. Let me know, thanks.

Customer: replied 1 year ago.
SOUNDS GOOD...THANK YOU
Expert:  Dan replied 1 year ago.

No problem, let me know how it goes and we will continue from there. Thanks.