How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask jazzmaster Your Own Question
jazzmaster
jazzmaster, ASE Certified Tech
Category: Buick
Satisfied Customers: 2951
Experience:  ase certified
8668911
Type Your Buick Question Here...
jazzmaster is online now
A new question is answered every 9 seconds

I have a 2003 Buick Park Avenue Ultra, I am using this

Customer Question

I have a 2003 Buick Park Avenue Ultra, I am using this vehicle for the winter, from Spring 2015 until now I did not use it, 2 days ago I tried to start it with a battery boost, as soon as I put the booster cables on I had power in the vehicle, I was waiting for about 2 minutes and then I started, I left the engine running, in about 10 minutes the engine shot off, I put the cables on again to start it but this time the car was not getting any power at all was completely dead, what you thing might be the problem?
Thank you,
Jim
Submitted: 1 year ago.
Category: Buick
Expert:  jazzmaster replied 1 year ago.

hi, you need to actually ,charge the battery on low charge -2 amps or so.and let it charge at least 4-6 hours

this brings a battery back to life after it goes dead .

when you first got it started and let it run ,the battery may not have had enough time to charge right by just sitting and running for 10 minutes,and certain circuits need a full charged battery to work .

also, it may have stalled because the idle relearn has to be done when its driven-that is the idle relearn work reset itself until it is driven .

if the battery doesn't take a good charge then it may be bad and it should be tested.

but it has to be charged at a low amp rate .....

it would be good to check the connecftions at the battery and check the connection of the hot and ground wires from the battery to the motor and starter .......jazzmaster ..

Expert:  jazzmaster replied 1 year ago.

if you still need help -please let me know.If I helped you please rate me positive and if need be can continue on ,,thank you ...jazzmaster

Related Buick Questions