How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ted G. Your Own Question
Ted G.
Ted G., Rigger, Diagnostician
Category: Boat
Satisfied Customers: 6159
Experience:  40 years boating, Safe boating instruct., Offshore Race promoter, Failure Analysis, Expert Witness
7183013
Type Your Boat Question Here...
Ted G. is online now
A new question is answered every 9 seconds

My diesel generator was overheating and shutting down so I

Customer Question

Hi my diesel generator was overheating and shutting down so I turned off the seacocks to check the impeller, but then decided to check the coolant and sure enough it was low, so I filled it opened the seacocjs and started the generator. Was running fine then presssure built up in the exhaust system and the exhaust hose that runs to the wet muffler blew off the muffler. Up to this it had been running perfectly and it was serviced at the start of the year. Any ideas??
JA: Sometimes things that you think will be really complicated end up being easy to fix. The Marine Mechanic I'm going to connect you with knows all the tricks and shortcuts. Is there anything else important you think the Marine Mechanic should know?
Customer: Water pump was leaking but i had that fixed. The outlet to the wet exhaust is under the boat. I think it's slowly burning coolant. That's it
Submitted: 1 month ago.
Category: Boat
Expert:  Ted G. replied 1 month ago.

If the exhaust outlet is under the boat I would suspect a clogged outlet. You could remove the hose at the sea cock and then open it to see how much flow comes in from outside, that should give an indication of a clog.

Customer: replied 1 month ago.
When I put the Cetus box back together. The hose connector has come out of the box. Do I need to use exahaust cement? Or just clamp it back in. The prints on the connector look good
Expert:  Ted G. replied 1 month ago.

I would try clamping it back in first. If you do need to glue it, you will probably need epoxy and then it is permanent.