How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

I have a 1998 maxim with a 5.7 alpha one tbv ifn, The enfi,

Customer Question

Hi I have a 1998 maxim with a 5.7 alpha one tbv ifn
JA: Sometimes things that you think will be really complicated end up being easy to fix. The Marine Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so the Marine Mechanic can help you best.
Customer: The enfi
JA: Is there anything else the Marine Mechanic should be aware of?
Customer: The eng starts fine but pings badly under under load
Submitted: 2 months ago.
Category: Boat
Customer: replied 2 months ago.
Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 2 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call.
Expert:  Tan replied 2 months ago.

Hello, I'm Tan. Welcome to JustAnswer. I'm reviewing your question and will reply momentarily.

Expert:  Tan replied 2 months ago.

We need to check for water in the fuel and the ignition timing. Your timing should be at 8* BTDC.

Customer: replied 2 months ago.
Fuel is new
While running the boat i can back off base timing by rotating the distributor and almost GE did of the ping
Customer: replied 2 months ago.
I meant get rid
Expert:  Tan replied 2 months ago.

What spark plugs are you using and what octane is the fuel?