How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Charles Your Own Question
Charles
Charles, Marine Mechanic
Category: Boat
Satisfied Customers: 3854
Experience:  US Navy (Ret) Certified Mercury Marine Tech with over a decade of repair experience.
67216606
Type Your Boat Question Here...
Charles is online now
A new question is answered every 9 seconds

HELP! I have a 2005 Sundancer with 2 5.0 mercruiser and

Customer Question

HELP! I have a 2005 Sundancer with 2 5.0 mercruiser and bravo 3 out drives. I lost com on both sets of guages and the mph center Guage .... I put new batteries in and both engines start on a dime. I pulled the guages out and checked the pins a few were lose. What is the possible issue for all to go out at the same time....Joel(###) ###-####..thanks
Submitted: 1 year ago.
Category: Boat
Expert:  Charles replied 1 year ago.

Hello, my name is***** will assist you.

Expert:  Charles replied 1 year ago.

The only thing that comes to mind on this would be that somehow you blew the fuses on the engines that control the gauges. There will be a fuse holder with several mini automotive style fuse inside it. Check and make sure that all the fuses are good still. If they are, test the gauge end of the harness for power. If you have power there, the tachs went bad.

Customer: replied 1 year ago.
It took to long...the problem was a power pin in the splitter box pulled out. All is good again...hope I am not charged...thanks though

Related Boat Questions