How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Cat Engine Expert
Category: Boat
Satisfied Customers: 8962
Experience:  23 years Caterpillar Engine Experience
30708357
Type Your Boat Question Here...
Cat Man is online now
A new question is answered every 9 seconds

Hey Cat Man, Today my Starbord engines oil Pressure gauge

Customer Question

Hey Cat Man,
Today my Starbord engines oil Pressure gauge spike and the alarm went off. At idle the guage is where it would normally be at 1500rpm. Any ideas?
thanks Chad
Submitted: 2 years ago.
Category: Boat
Customer: replied 2 years ago.
Checked oil level,all good.
Expert:  Cat Man replied 2 years ago.
Hi Chad. Thanks for asking your question and requesting me! I will try and help you out.
I would first suspect a faulty oil pressure sensor. I have seen this before. To confirm you could connect a psi gauge to verify the pressure. It's not common to have oil pump problems on the 3208. The pump is normally very reliable.
Please reply back if you need more help or have more questions. I am happy to assist.
Expert:  Cat Man replied 2 years ago.
Hey. I just wanted to see how things were going. Please let me know if you need more help. I am happy to assist. If my information was helpful, please leave a good or higher rating so that I receive credit. Thanks.
Customer: replied 2 years ago.
Turns out it was a faulty ground that was causing the ECM to read faulty codes. I grounded the negative terminal on the starter to the block with a #1 wire. Problem solved!!
Expert:  Cat Man replied 2 years ago.
That's great news. I'm glad you got it fixed. Good Job!