How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask exptech2015 Your Own Question
exptech2015
exptech2015,
Category: BMW
Satisfied Customers: 1537
95415974
Type Your BMW Question Here...
exptech2015 is online now
A new question is answered every 9 seconds

I get error code 59 on my m3 e46 55 plate The car drives

This answer was rated:

Hi guys
I get error code 59 on my m3 e46 55 plate
The car drives good but it’s changes gears slowly but still drives I’ve had this problem for 3 months and my mechanic says it’s the clutch actuator? The orange light comes up on dash mechanic resets computer and light goes of but code still there
I’ve changed the clutch smg pump , is it the actuator that’s gone on the sensor
Thanks
Nick

find out code for me will you. it can be scanned at autozone free

then get me the vin number so I can research this issue you are having with your vehicle

Customer: replied 7 months ago.
The code is 59 mentioned earlier
Will get vin later

O​H P059

Customer: replied 7 months ago.
No it just says error code 59 just trying to get more info about software update from Bmw uk
Customer: replied 7 months ago.
The car drives but get warning light coming up may be once every month

I​TS AN AUTOMATIC? MILEAGE? AND HAS FLUID EVER BEEN SERVICED. PROBABLY HAS NO DIPSTICK CORRECT? SINCE ITS A UK MODEL IM LIMITED ON WHAT I CAN DO ON THIS SIDE OF ATLANTIC. BUT THERE ARE maNY COMMON GROUND FACTORS THAT ARE UNIVERSAL. I am looking up p059 as well it may be the same code over here as well

we have the vehicle over here too. it only comes up as a standard transmission. I will now ck code for any relevant helpful info

Customer: replied 7 months ago.
It’s a smg triptronic semi auto, mileage 85k

Before reading my answer below, please note that you must press the green ACCEPT button in order for me to receive credit for my time and effort. Thank you.

First thing to do is check the fluid level to make sure it is full.

If the fluid checks out okay, then this could possibly be caused by a bad output speed sensor, on internal wear.

You would need to have further testing carried out by either BMW or a good transmission shop to verify, however, as it is not possible to say 100% which is the problem with only that code to go on.

Also could possibly be a bad connection or loose cable somewhere as well.

I hope that is helpful, please let me know if you have further questions, or if I can clarify anything for you.

It has been my pleasure to help today and I wish you the best of luck with the vehicle.

If satisfied with my assistance, please press the green "ACCEPT" button so that I may be credited for helping today. I am not credited or compensated whatsoever until you press the green ACCEPT button.

The sensor requires the transmission pan to be removed.

If there is internal wear and slippage, you will need a replacement transmission or a complete rebuild.

Please let me know if you have further questions.

Since I have answered your question, I would kindly ask that you please press "ACCEPT" so that I receive credit for doing so.

Customer: replied 7 months ago.
Where’s the accept button

th​ey may have changed system around a little. Were you happy with my service. just not sure how to rate?

thank you for choosing Just Answer and have a pleasant evening

exptech2015 and 3 other BMW Specialists are ready to help you
Customer: replied 7 months ago.
Thank you
Appreciate your help
Have a good evening