How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: BMW
Satisfied Customers: 22983
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your BMW Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

The cooling fan runs at full speed on cold start. once i

Customer Question

the cooling fan runs at full speed on cold start. once i push a full troughe
JA: Will the headlights turn on? Is the battery fully charged?
Customer: i changed the battery lately yes sometime the headlight turns on while it still daylight
JA: What is the model/year of your BMW?
Customer: 325i 2006
JA: Are you fixing your 325i yourself? What have you tried so far?
Customer: tested all the sensors
JA: Anything else you want the mechanic to know before I connect you?
Customer: the fan run normally when the car is hot. it does not run when the car start when hot.
Submitted: 8 months ago.
Category: BMW
Expert:  Dan replied 8 months ago.

Hello, my name is ***** ***** I'm here to help get your problem solved.

Expert:  Dan replied 8 months ago.

It sounds like the fan control module has probably failed. Disconnect the cooling fan temperature sensor, on the right side of the radiator. If the fan stops, replace the sensor. If it does not, disconnect the 3-wire connector at the fan control module, mounted on the back of the fan motor. That should always stop the fan motor. Check for power on the small-gauge Black/Green wire to the fan control module. It should have none with the ignition off and a cool engine. If there is no power on this wire, replace the fan control module. Let me know if you have more questions, thanks.

Customer: replied 8 months ago.
i did not mention before that the fan stops if i apply a full throttle for a while.
regarding the sensor, i have tried it when the car is not cold and the fan is off.
once i remove the plug the fan runs as failsafe.
Expert:  Dan replied 8 months ago.

Without a scantool to monitor sensor data it is going to be impossible to determine if problem is sensor or module. Since problem seems to be temp related I would start by replacing sensor. Let me know if you have questions, thanks.

Customer: replied 8 months ago.
i have a scan tool and monitored the sensors and all sensors are good.
Expert:  Dan replied 8 months ago.

Ok, then with that said I don't see any other possible problem besides the cooling fan control module. It is possible ECM but I have never seen ECM cause cooling fan issues. Let me know how it goes or if you have more questions, thanks.

Customer: replied 8 months ago.
Hello Dan,
in this sentence there is a contradiction:
Check for power on the small-gauge Black/Green wire to the fan control module. It should have none with the ignition off and a cool engine. If there is no power on this wire, replace the fan control module.
can you please review it.
Expert:  Dan replied 8 months ago.

If it has voltage with key off that means fan control module has failed.

Customer: replied 8 months ago.
Hello Dan,
Sorry for the late reply. I was buying a new fan to test it.
Unfortunately it did not work, I am getting the same behavior as before. Fan running on cold start and then work normally.
I noticed also that the fan run normally after I turn on the air conditioning for some seconds.
Expert:  sprinkles08 replied 8 months ago.

Hello and welcome to JustAnswer!

Do you still need help?

Customer: replied 8 months ago.
as i have mentioned before, the solution did not work.
which sensor might cause this? how can i check it?
the car works normally when it turns hot.
Expert:  sprinkles08 replied 8 months ago.

As mentioned previously the most likely cause for this would be the fan controller and a scan tool is necessary to diagnose the issue. Do you have a scan tool to monitor ECM data?

Customer: replied 8 months ago.
I have changed the fan controller with a new one but I am still having the same issue.
yes I can monitor the ECM data. Please advise what should be done.
Expert:  sprinkles08 replied 8 months ago.

What was the part number of what you replaced? You mentioned replacing the fan itself previously.

Customer: replied 8 months ago.
it is the complete cooling fan assembly. it is one part include the fan and the control unit.
My car is BMW v325I 2006.
Expert:  sprinkles08 replied 8 months ago.

What is the fan duty cycle at the time its running when you don't' believe it should?

Customer: replied 8 months ago.
The fan runs on cold start. (when the car is off for several hours.)
it stops if I turn on the AC, if I go full throttle for a while, if I turn off the car when it is on normal temp and turn it back on.
Expert:  sprinkles08 replied 8 months ago.

What is the fan duty cycle at the time its running when you don't believe it should?

Customer: replied 8 months ago.
please explain your question.
Expert:  sprinkles08 replied 8 months ago.

Use the scan tool to enter ECM data and look at commanded fan duty cycle when the fan is running but you think it shouldn't be.