How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 29071
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

My BA ford XR6 2005 mkII has no spark/fuel/ or power to

Customer Question

Hi my BA ford XR6 2005 mkII has no spark/fuel/ or power to throttle body plugs I have a mechanic scan for codes and it came up with transmission not connecting to ecu
JA: Has the vehicle turned into a gas hog? And how does it start -- same as usual?
Customer: The hasn't been running for a few months now due to this issue prior to this it would only run when it felt like it maybe 1 out of every 10 starts
JA: What is the model of your '05 Ford?
Customer: BA XR6 mkII non turbo
JA: Are you fixing your Turbo yourself? What have you tried so far?
Customer: Is a non turbo engine so no turbo I have done ecu/pcm/bcm/ICC unit/crank angle sensor
JA: Anything else you want the mechanic to know before I connect you?
Customer: Yes how to fix my car please
Submitted: 2 months ago.
Category: Australia Car
Customer: replied 2 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call.
Customer: replied 2 months ago.
Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Pete replied 2 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Unfortunately I am unable to place a call on this here myself but others see you have requested a call and may still call on this here.I can however continue here.

Inspect the wiring leading from the ecm itself for any issues as damaged or corroded or even shorted wiring can cause this type of fault here.If this is or was already checked and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated ( should be a link to click on here or above).You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete