How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 29037
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I have the same problem relays are near the factory tow bar

Customer Question

i have the same problem relays are near the factory tow bar rear left hand 1/4 panel 2014 triton no tail/brake on trailer wtf
JA: What confuses you?
Customer: relays clicking no power to trailer brake tail lights
JA: Is the power loss consistent, or does it fluctuate?
Customer: nothing at all
JA: What is the model of your '14 Mitsubishi?
Customer: mn triton
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: changed relays have power there with test light no power at trailer plug do have indicators
JA: Anything else you want the mechanic to know before I connect you?
Customer: only clear advice to where there may be a trailer harness fuse ect thank you
Submitted: 2 months ago.
Category: Australia Car
Expert:  Pete replied 2 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

The most common cause for this issue here is damaged or corroded wiring.I would inspect the trailer plug wiring and connection for any corrosion or damage needing repaired or replaced.This is the most common cause and you may need to trace the harness to locate the issue.If this is checked and found o.k. let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated ( should be a link to click on here or above).You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 2 months ago.
mate the car is a little over three years old live in alice springs no much corrosion up here, there is none at the plug wires they still look like new . I thought it must be something other than that because there are a few complaints of the same thing on the net , damage and corrosion is the first thing I checked that's why I checked with a so called expert
Expert:  Pete replied 2 months ago.

Unfortunately this is all of the info I show on this myself here.I will have to see if anyone else can assist further on this.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Customer: replied 2 months ago.
cheers ***** ***** for future reference when Mitsubishi fit a tow bar they run a wire up to the battery which I think power the relays to atail & brake so in the event of a short you don't loose youre tail/brake lights. well hanging below the pos terminal behind the battery box is a cheap looking rubber fuse holder out of sight bingo