How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis Your Own Question
Curtis
Curtis, Australia Car Mechanic
Category: Australia Car
Satisfied Customers: 1609
Experience:  Qualified Automotive Mechanic, LPG & Airconditioning Diagnostic Technician.
29271542
Type Your Australia Car Question Here...
Curtis is online now
A new question is answered every 9 seconds

My Hyundai Getz is a 2011 5 door manual SX. The radio MP3WMA

Customer Question

My Hyundai Getz is a 2011 5 door manual SX. The radio MP3WMA recently starting playing up. The screen illuminates but there is no writing (Hyundai usually appears then it connects to bluetooth etc.) The screen remains illuminated but there is only a horrible white noise as though it is slightly off a radio station and there is a faint radio station sound underneath this noise - both only coming from right speaker. Nothing works on the unit. I can't turn it off or down or change the mode. I have removed the audio fuse so I can drive without the loud white noise but I'm wondering if it can be fixed or whether I need to replace the unit
JA: Most vehicles have two fuse panels. Have you located both?
Customer: The audio fuse was under the drivers front dashboard. Where is the other located?
JA: What is the model of your '11 Hyundai?
Customer: Ok the service book says 09 5dr Getz 1.6 SX with ESP Manual
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: Just removing the fuse that inactivated the audio.
JA: Anything else you want the mechanic to know before I connect you?
Customer: I have been talking to my mechanic re whether to replce with a second hand Hyundai radio or get a sony or the like I just seems weird that it was working perfectly and then wasn't as though it is a computer issue for it that might be able to be reset or something
Submitted: 2 months ago.
Category: Australia Car
Expert:  Shawn Few replied 2 months ago.

Hey ,how are you
I seen That your post been sitting for a long time without an answer ,I 'm sorry for your long wait without getting an answer till now
I will try to help you on this issue if you have not gotten it resolved yet
Please Let Me Know
Thank You
ASE Certified Technician

I would definitely a Sony