How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 28814
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I have had battery issues but it always started when jump

Customer Question

I have had battery issues but it always started when jump stated Cnut I bought a new battery and had been fine. It won't turn over at all there just nothing when I turn The. No lights nothing. I changed the battery in the immobilizer but still nothing.
JA: Will the headlights turn on? Is the battery fully charged?
Customer: No light won't turn on either I put another battery out of my other car in it that does work and still nothing
JA: What is the model/year of your Subaru?
Customer: 1998 Subaru imprezer
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Just changing over battery. Jump stating and replacing battery in the immobilizer
JA: Anything else you think the mechanic should know?
Customer: When I bought it, it was due for a service but hasn't been done yet. I've always managed to get it going by swapping batteries or jump starting it but I noticed this morning that my daughter had left the headlight on but it hasn't been driven for at least 3 weeks
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Subaru Mechanic about your situation and then connect you two.
Submitted: 1 year ago.
Category: Australia Car
Customer: replied 1 year ago.
Hi I still haven't received reply yet to the above question thanks
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

This sounds like a possible fault with a loose or corroded battery cable at the battery or leading from the battery needing either cleaned and tightened or replaced to correct this fault here.I have seen this as an issue before and had to correct the cable issues for this fault here.If this has not been checked this needs done to see if this is the cause here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete