How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Australia Car
Satisfied Customers: 22654
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Australia Car Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Ford au: glen I have mk 1 au trans is slow to engage when

Customer Question

hi glen I have mk 1 au trans is slow to engage when put in drive also when I come to a stop sometimes it dose not change down it has no drive rev it and it finds drive I just serviced it no change thanks barryt
Submitted: 2 years ago.
Category: Australia Car
Expert:  sprinkles08 replied 2 years ago.
Hello and welcome to JustAnswer!
This could definitely be an internal failure but these symptoms are often caused by low fluid level. It's possible you could have a failing clutch or pump issue, but if the pump sucks air due to low fluid level, a damaged filter or the filter not being installed correctly it will cause exactly what you're describing.
The problem was present both before and after replacing the fluid?
Has the level been rechecked after initially driving it to make sure it wasn't left low?
Have you checked for fault codes?