How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask gomi_otaku Your Own Question
gomi_otaku
gomi_otaku, Technician
Category: Audi
Satisfied Customers: 3457
Experience:  VW certified technician, Chicago VW/Audi Training Center, Seattle VW/Audi Academy
12249065
Type Your Audi Question Here...
gomi_otaku is online now
A new question is answered every 9 seconds

My name is coen and i have an audi a4 b6 and its suddenly

Customer Question

Customer: hi, my name is ***** ***** i have an audi a4 b6 and its suddenly stopped starting
JA: Thanks. Can you give me any more details about your issue?
Customer: the starter motor cranks without an issue but there is no spark the fuel pump is also working and iv checked all the fuses
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Audi Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: yeah no worries
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Audi
Expert:  gomi_otaku replied 1 year ago.

what year is your car? Do you have any scan tool to read fault codes?

It sounds to me (since there is no spark) that you have a failed crank sensor. Do you normally get a check engine light that comes on when you turn the key on (self check of systems) and does it stay on if you do not start the car (indicating the ECM is communicating)

Customer: replied 1 year ago.
It's a late 01 b6 and no I don't have a scan toolAnd I do get all the lights come up but they turn off the only one that stays on is epc but it turns off when I crank the engine
Expert:  gomi_otaku replied 1 year ago.

OK, that's normal as the other systems are cut off to direct all power to the starter.

Have you checked the timing belt to make sure it is OK?

Customer: replied 1 year ago.
yeah the timing belt is okay it happened after i replaced the ecu cover so im guessing it has something to do in that area
Customer: replied 1 year ago.
would a bad 219 relay be causing the issue
Expert:  gomi_otaku replied 1 year ago.

It could- you may want to inspect the connector under the relay to make sure the terminals on the wire ends are OK and making good contact with the pins on the relay.

Customer: replied 1 year ago.
there are 2 pins on the relay that look shorted
Customer: replied 1 year ago.
what is the 219 relay for?
Expert:  gomi_otaku replied 1 year ago.

That's the ECM power relay. What do you mean by they look "shorted"? Often, due to the amount of power running through a relay one of the pins may look heated and discolored but that is normal.

Customer: replied 1 year ago.
2 pins are black at the bottom of the pins
Expert:  gomi_otaku replied 1 year ago.

If you have someone else to help you, make sure that relay "clicks" when you turn the key from off to on. Discoloration is just a sign of heating, but if the terminals are actually stuck open it may cause a problem. If they were stuck closed then the ECM would never power down, your battery would probably die.