How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Your Own Question
John
John, Home Appliance Technician
Category: Appliance
Satisfied Customers: 13453
Experience:  Appliance repair business owner for over 43 years.
12064207
Type Your Appliance Question Here...
John is online now
A new question is answered every 9 seconds

I have a Kenmore Electric Range model 790.97453804. The oven

Customer Question

I have a Kenmore Electric Range model 790.97453804. The oven will rise in temp about 1 degree per minute. The broil function does not work. The stove top, lights, and display all function fine with no error codes. I have removed both elements and both work properly using an ohms meter. No wires appear to be burned or damaged.
JA: Can you guesstimate how old your Kenmore is? And just to clarify, what's the exact model?
Customer: The stove came with the home which we purchased 6 years ago. Model number from the tag on the frame is 790.97453804. SN of VF94443278.
JA: Do you plan on doing the work yourself?
Customer: yes
JA: Anything else we should know to help you best?
Customer: This is the first time it has had any issues. In 10 minutes on bake, the temp has raised to 157 degrees F.
Submitted: 11 days ago.
Category: Appliance
Expert:  Kelly replied 11 days ago.

Thanks for counting on us to help with your appliance problem. My name is ***** ***** I look forward to helping you!

Expert:  Kelly replied 11 days ago.

Does the bake element get red hot?

Customer: replied 11 days ago.
no
Expert:  Kelly replied 11 days ago.

Are you comfortable testing live voltage?

Customer: replied 11 days ago.
Expert:  Kelly replied 11 days ago.

Can you turn the oven to bake and measure the voltage at the elements, looking for 240 VAC between the two wires at the elements?