How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Your Own Question
John
John, Home Appliance Technician
Category: Appliance
Satisfied Customers: 13453
Experience:  Appliance repair business owner for over 43 years.
12064207
Type Your Appliance Question Here...
John is online now
A new question is answered every 9 seconds

I have a samsung side by side refrigerator mod

Customer Question

I have a samsung side by side refrigerator mod RSB307AARS\XAA. I have Tried several Samsung Filters and it won't dispense water. When filter is removed the water runs out fine from the dispenser. How can I purchase a new solenoid/water inlet valve because it seems that is the problem
JA: Can you guesstimate how old your Samsung is? And just to clarify, what's the exact model?
Customer: Model number is *****\XAA and the refrigerator is about 4 or 5 years old. Side by side.
JA: Do you plan on doing the work yourself?
Customer: My husband will hopefully.
JA: Anything else we should know to help you best?
Customer: Out of work currently and trying to just replace the part. The filter are all undamaged, and OEM Samsung filters. Water works fine with out a filter.
Submitted: 11 months ago.
Category: Appliance
Expert:  Kelly replied 11 months ago.

Thanks for counting on us to help with your appliance problem. My name is ***** ***** I look forward to helping you!

Expert:  Kelly replied 11 months ago.

If it dispenses fine with the filter out, it has to be an issues with the filter housing, not the valve. The bypass is working, so we know the valve is okay. It has to be either the filters or the filter housing. Are you using OEM filters or aftermarket ones?

Customer: replied 11 months ago.
The water filter housing is original OEM. The filters are OEM. We have tried several filters thinking it was a filter issue. When we take off filter water flow/pressure is fine. When we attach filter pressure is very low or no flow at all.
Expert:  Kelly replied 11 months ago.

So the issue has to be in the filter housing that directs the water through the filter. Please allow me just a few minutes to prepare some information for you, thank you!

Customer: replied 11 months ago.
We found the answer online after reaching out to you and we need to cancel membership to just answer.com
Expert:  Kelly replied 11 months ago.

LOL, ok. Good luck....