How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kelly Your Own Question
Kelly
Kelly, Appliance Technician
Category: Appliance
Satisfied Customers: 22588
Experience:  Highly accurate diagnostician with over 30 years experience!
11418111
Type Your Appliance Question Here...
Kelly is online now
A new question is answered every 9 seconds

I have a Dacor PGR 30 (approx 15 yrs old). I just replaced

Customer Question

I have a Dacor PGR 30 (approx 15 yrs old). I just replaced the ERC 4800 Controller 62789 and the relay board 62438. I have 120V to the DBL (double line relay) NO side. In Bake Mode, I have 120V at the DBL (double line relay) com. The cooling fan does not run. If I jumper the cooling fan to the DBL com terminal, the cooling fan motor runs. In any of the Bake/Broil modes, I do not see voltage at the CLF terminal on the main relay board. I disconnected the cooling fan assembly and looked for an air switch/sail switch but did not see one on the cooling fan carriage. What now?
Submitted: 1 year ago.
Category: Appliance
Expert:  Kelly replied 1 year ago.

Hi, welcome to Just Answer. Sorry to hear you are having appliance trouble, I know how frustrating that can be! My name is ***** ***** I look forward to helping you!

There has to be an issue with the relay board, see the attached page. What part number did you replace?

Customer: replied 1 year ago.
I replaced Relay Board 62438
Customer: replied 1 year ago.
I have the page you sent. I am hoping you can provide me with better details
Expert:  Kelly replied 1 year ago.

The fan will not turn on until the sensor reads about 200* F. Are you allowing heat time before checking?

Customer: replied 1 year ago.
The preheat temperature first displays 135 and does not rise from there. The Broil cycle works heating up the oven quite well but the cooling fan never comes on.
Expert:  Kelly replied 1 year ago.

So the bake element is not heating?

Customer: replied 1 year ago.
Could it be that the bake igniter failed again?
Expert:  Kelly replied 1 year ago.

Sure, if it is not getting hot. It should draw around 3.5 amps when it is on and the burner should light in about 60 seconds or less.

Customer: replied 1 year ago.
If the bake igniter is broken, I take it from your last response, that the oven wont get to 200 and the CLF pin will not develop 120V. Is that correct... if so, I guess I am going to buy another bake igniter.
Expert:  Kelly replied 1 year ago.

That is correct. Can you see the orange glow from the vents in the oven floor?

Customer: replied 1 year ago.
I took the bottom oven tray out and the bake igniter is stone cold. So... I guess that is the problem.
Expert:  Kelly replied 1 year ago.

I would agree, considering the relay board is new.

Customer: replied 1 year ago.
Ok. thanks for your help. Bye
Expert:  Kelly replied 1 year ago.

The link below is to the part you will need from a highly recommended company rated A+ with the Better Business Bureau. They offer a 100% money back guarantee, EVEN ON INSTALLED ELECTRICAL PARTS, for an entire year! They are the only company to allow returns on installed parts for a refund and offer a FULL ONE YEAR WARRANTY!

CLICK HERE

The universal one below is the same igniter....

CLICK HERE

Thank you so much! Please let me know if you have additional questions or need clarification. Please remember to rate before you leave, using the stars at the top of the page.

Customer: replied 1 year ago.
issue is not resolved. your office said that I could ask you to continue it. I replaced the bake igniter. I see 120V at the bake relay but the igniter stays cold.
Expert:  Kelly replied 1 year ago.

Are you getting any voltage at the igniter?