How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tyler Z. Your Own Question
Tyler Z.
Tyler Z., Appliance Doc
Category: Appliance
Satisfied Customers: 81154
Experience:  9+ years being an appliance technician with factory training.
13574879
Type Your Appliance Question Here...
Tyler Z. is online now
A new question is answered every 9 seconds

I have a Kenmore HE2 Plus Mod.#110.47532600 Front loader.

Customer Question

I have a Kenmore HE2 Plus Mod.#110.47532600 Front loader. Error coding F-21 or 2-D. I have learned on-line that it is made by whirlpool but can't find codes higher than F- 15. It is shutting down undrained. I have drained it, cleaned the screen, checked that the impeller is free (it kind of lopes when you turn by finger), checked the out going drain hose and using a voltage detector, determined that the wires to the drain pump do energize when I start a Rinse/Drain cycle. But impeller didn't turn. I'm guessing I need a new pump but I would feel better about my diagnosis if I knew what the fault codes meant. I know nothing about appliances I'm just a construction guy with a voltage tester/detector. My previous attempt at appliance repair have not gone so well. Can you help?
Submitted: 8 years ago.
Category: Appliance
Expert:  Tyler Z. replied 8 years ago.
F21 litterally means that the machine is not detecting that all the water has been drained out of the machine. Your exactly right in that the drain pump needs to be replaced if it's getting 120 volts and the impeller is not moving because that is what would be giving the fault.
Tyler Z. and 4 other Appliance Specialists are ready to help you
Customer: replied 8 years ago.
I took the pump out and hot wired it with 110 and it spun. Turns out the pump motor leads show voltage with a voltage detector all the time when the machine is in operation even when the pump is not supposed to be pumping. Huh. Put it back in, watched an entire cycle. Pump actvated and worked however the machine had trouble going into high spin. Pump kept working but never did purge all of the water. Finally the pump motor got hot with one minute left and F33 coded. I'm thinking the impeller is wore because it was turning. Does this sound plauseable? Would you think I should replace just the pump or the motor too?
Expert:  Tyler Z. replied 8 years ago.
well the pump motor only comes as one assembly so you can't replace pieces to the pump motor. F33 is actually a water intake issue. The machine is not detecting water coming into the machine when it's telling it to. Now you'll have to pay attention to when the error occurs.

First turn the cyle to just the 15 min drain cycle and the unit should run fine if it has nothing to do with the drain pump or the control boards.

If this is the case then you might be getting an error just before it drains when it's supposed to be rinsing either because water is coming in too slow or it might not be sensing the water correct---or you couls just have a bad control board.
Customer: replied 8 years ago.
Controls do not offer a drain only cycle. On the rinse/drain cycle it filled, oscillated, drained, started to spin slowly several times stopped and oscillated a bit more then started to spin slowly, the oscillated several times, finally started to kick into a higher spin, but seemed to slow before reaching a good sustained spin, thought I could hear water inside. Then shut down at 1 minute, could smell hot electrical smell, pump motor was hot, F33 displayed. I manually drained approx. one gallon of water out the drain.
Expert:  Tyler Z. replied 8 years ago.
This is what the manufacturer is saying about F33 but it doesn't seem to make any sense based on what your saying.

If after 30 seconds the control does not detect water
entering machine, the valves will be turned off and the error
code will be displayed.ORIf the control has turned the
water valves on and after 8 minutes the flow sensor has
detected 10.5 gallons of water passing through it, but has
not detected the pressure switch trip, the valves will be
turned off and the error code will flash.
Press PAUSE/CANCEL twice to clear the display.

Possible Causes/Procedure
1. Check for crack or holes in the washer tub and pressure
switch hose.
2. Replace components if necessary.
Customer: replied 8 years ago.
I guess I'll replace the pump and go from there.
Expert:  Tyler Z. replied 8 years ago.
yeah I can't say for sure, that's what F21 meant but F33 is something completely different, it sounds like you might have a control board issue especially getting 2 different errors.