How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bryan Your Own Question
Bryan
Bryan, Home Appliance Technician
Category: Appliance
Satisfied Customers: 12156
Experience:  15 yrs. experience as a certified appliance technician.
10522817
Type Your Appliance Question Here...
Bryan is online now
A new question is answered every 9 seconds

I have a Whrilpool super capacity 465. The stove will not ...

Customer Question

I have a Whrilpool super capacity 465. The stove will not ingnite when i turn it on. All it does is click for five seconds then it stops.
Submitted: 9 years ago.
Category: Appliance
Expert:  Bryan replied 9 years ago.
Hi this is Bryan. is it all of your burners. or just one? you are talking about top burners right? let me know. Bryan
Customer: replied 9 years ago.
Reply to a1speedyappliance's Post: All the burners on top of the stove work. It is the oven (area where you bake) that will not ignite. The burners ontop ignite just fine.
Expert:  Bryan replied 9 years ago.
ok , can you give me full model #? i'll look up oven and get back to you, thanks Bryan
Customer: replied 9 years ago.
The model number is XXXXX   5, Whirlpool.
Expert:  Bryan replied 9 years ago.
yoyr oven shows it has an ignitor for oven , thats what your problem is.. you can click on this link to find ignitor www.pcappliancerepair.com change the bottom one and it should work fine , thanks Bryan. feedback is appreciated and helps rate experts. please press accept if your happy with answer .thanks again Bryan
Bryan and other Appliance Specialists are ready to help you
Customer: replied 9 years ago.
I replaced the ignitor, the oven still makes that clicking noise, the oven does not ignite. Do you have any other advice?
Expert:  Bryan replied 9 years ago.
well maybe the wire going to ignitor has a break in it. let me do some checking I'll be back in a little while. thanks Bryan