How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Agriculture and Farm Equipment
Satisfied Customers: 28915
Experience:  Technican turned service manager on multiple lines of equipment and rental equipment.
30244710
Type Your Agriculture and Farm Equipment Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Zd326S. Bled injectors. Fuel pumps out of fuel filter.

Customer Question

Zd326S. Bled injectors. Fuel pumps out of fuel filter. Cranks fine. No fuses blown i can see. Was running fine, then stopped. That was it. 350 hours. Had been running fine. Did this once before and had to go to dealer. An oyed as hell.
Submitted: 1 year ago.
Category: Agriculture and Farm Equipment
Expert:  Curtis B. replied 1 year ago.

Check the fule solenoid, slip it back and see if the engine will start. See picture below.

Expert:  Curtis B. replied 1 year ago.

Mounted just to the left of the injector pump body.

Expert:  Curtis B. replied 1 year ago.

my response shows as customer!

Customer: replied 1 year ago.
What mean by 'slip it back?'
Expert:  Curtis B. replied 1 year ago.

Unbolt the solenoid and slip it back , so it does not touch the inner linkage of the injection pump. It pushes against the linkage and shuts off the fuel . You saw the picture I sent?

Customer: replied 1 year ago.
Expert:  Curtis B. replied 1 year ago.

If the linkage does not go to the open position, you get no fuel to the injectors. No smoke from exhaust , so you are not getting fuel to the cylinders.

Customer: replied 1 year ago.
Did that. No start.
Expert:  Curtis B. replied 1 year ago.

Ok, with it out, feel up in the housing and push on the linkage, it should be spring loaded. It should push in and when released, return to the starting position. Do you feel it doing anything?

Expert:  Curtis B. replied 1 year ago.

If it does not move, see if you can get a wire i=on it and pull it outwards.

Customer: replied 1 year ago.
Got in there. Pushed in and out easily with my finger if that was the right thing. Decent smoke now coming out of exhaust.
Expert:  Curtis B. replied 1 year ago.

I bet it will start now, with glow plugs warmed.

Customer: replied 1 year ago.
Still no start.
Expert:  Curtis B. replied 1 year ago.

If you loosen high pressure fuel lines , do you now have fuel squirting? If not squirting, the injection pump is still not in the open position! With engine quitting under use, you can have internal failure with fuel camshaft or the camshaft of the engine. Have you had the rocker cover off, to check the valve movement?

Expert:  Curtis B. replied 1 year ago.

Did you find problem?