How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Solis Your Own Question
Michael Solis
Michael Solis,
Category: Acura
Satisfied Customers: 172
Experience:  Lead Tech at Solis Auto Repair
99786211
Type Your Acura Question Here...
Michael Solis is online now
A new question is answered every 9 seconds

04 TL....i replaced the stereo amp with a used identical amp

Customer Question

04 TL....i replaced the stereo amp with a used identical amp and now my climate control display does not illuminate....the climate controls don't work, the clock display doesn't work, the odometer trip meter displays and resets to zero when the car is started...the remote doesn't work...door locks work when on...the radio works great but no display.....i don't see any fuses blown and i have disconnedted the battary and replaced the old amp back in but with the same results....
JA: Most vehicles have two fuse panels. Have you located both?
Customer: yes
JA: Are you fixing your TL yourself? What have you tried so far?
Customer: just what i have typed
JA: Anything else you want the mechanic to know before I connect you?
Customer: no I think that is it
Submitted: 1 month ago.
Category: Acura
Expert:  Michael Solis replied 1 month ago.

Hello, my name is***** will be helping you out! I have over thirteen year of experience in the automotive world for numerous different makes & models. I enjoy doing what I do, it is my life. I just did extensive research on your issue, I believe I know where the problem lies. Let me know if I can help!

Customer: replied 1 month ago.
Hi Michael, what do think the problem is?
Expert:  Michael Solis replied 1 month ago.
All of those things that you have listed all lead to a ground they all share. Guess where the ground is? Right next to the amplifier you replaced. See if it is not off or loose I'll attach a picture of it
Customer: replied 1 month ago.
I'm not able to look at my car at the moment, but this doesn't appear to be a picture of my car...the amp is located on the right floorboard adjacent to the glove compartment...the pictures states "middle of dashboard"
Expert:  Michael Solis replied 1 month ago.

ok let me look into it more

Expert:  Michael Solis replied 1 month ago.

my apologies, its this one

Expert:  Michael Solis replied 1 month ago.

Have you looked at the ground?

Expert:  Michael Solis replied 1 month ago.

any updates?

Expert:  Michael Solis replied 1 month ago.

I see you have given me a negative rating. I am here for you until the end, if I was not helpful, then please tell me why. I could have easily give other options. I work very hard in what I do & satisfactions is my number 1 priority I also could have opted out and gave another tech an opportunity to help you. I respond very quickly. The negative rating deeply affects me in all ways possible and it hurts only me. You could have at least replied back and explain more than just giving me a negative. Please tell me if there is anything else I can do for you, otherwise I can still gladly opt out if you like. If there was incorrect information I could easily correct with the vin number or simply opt out. If you were not satisfied, I would even flag for request for refund, but the negative rating deeply hurts me & only me. If there is something else I can manage to do for you, please respond and let me know.