How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask thebesthonda Your Own Question
thebesthonda
thebesthonda, ASE MasterTechnician
Category: Acura
Satisfied Customers: 783
Experience:  26 years experience
14931499
Type Your Acura Question Here...
thebesthonda is online now
A new question is answered every 9 seconds

2000 Acura RL multiple issues, but ignition doesn't kill the

Customer Question

2000 Acura RL multiple issues, but ignition doesn't kill the accesories in off postion, thus allowing NAV and stereo to drain battery when parked for over 12 hours, fog lites don't light up when button is pushed, but left signal comes on ancd stays on, I can't seem to enter time, signals operateintermitently
JA: Have you checked the fuse?
Customer: yes... fuses are all good
JA: What is the model of your '00 Acura?
Customer: RL
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: looked at fuses, all good, but after noticing the radio stayed on after key was removed and door was open, that problem became my top priority
JA: Anything else you want the mechanic to know before I connect you?
Customer: not at the moment
Submitted: 1 month ago.
Category: Acura
Expert:  PLCUSTOMER-mzof8sxf- replied 1 month ago.

Hello thank you for contact Just Answer

Expert:  PLCUSTOMER-mzof8sxf- replied 1 month ago.

I will be able to help you with your issue.

Can you please tell me what "accessories" remain on when you remove the key from the vehicle?

This will help me further diagnose your problem.

Thank you!

Customer: replied 1 month ago.
It seems as though the swith is still in accessory mode. Just the navigation and stereo that I can tell... and bell for key in ignition
Expert:  PLCUSTOMER-mzof8sxf- replied 1 month ago.

Hello,

Thats great information. The ignition switch has sliding contacts "pins" inside of the switch. Sometimes these pins move and get dislocated inside the ignition switch.

To test, remove the igniton switch and probe the following wire, YELLOW (+) wire and ground. if you see 12 volts, you have a internal short in the switch. I recommend changing the ignition switch.

Please remember if you found me helpful, please rate my response! Thanks again!

Expert:  PLCUSTOMER-mzof8sxf- replied 29 days ago.

Hello,

Were you able to use my information to diagnose your issue?

Thank you!

Customer: replied 26 days ago.
I was expecting not to have to repeat everything I wrote in my innitial question. ... I knew how to check ugnition and wires... I was simply hoping someone else experienced these things and were able to fix it.