How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask HONDASERVICE7791 Your Own Question
HONDASERVICE7791
HONDASERVICE7791, TECHNICIAN
Category: Acura
Satisfied Customers: 2036
Experience:  OVER 20 YRS EXPERIENCE, OVER 10 YRS ACURA/HONDA EXPERIENCE
8532170
Type Your Acura Question Here...
HONDASERVICE7791 is online now
A new question is answered every 9 seconds

RL: Hi,pls i have 1999 acura rl 3.5 and i have a check engine

This answer was rated:

Hi,pls i have 1999 acura rl 3.5 and i have a check engine light on and off but when it was on it throws a code P0170 AND P0172 but right now the check engine light is off pls what is going on and i discovered that i dont get the right gas mileage.also i have ABS and TCS LIGHT ON PLS HELP.MAYO

HONDASERVICE7791 :

Hello and welcome to justanswer.com, it would seem that you have two issues here. first let me ask a few questions: how many miles on the vehicle? Have you had a recent work performed? have you been staying up to date on the services that are recommended?

JACUSTOMER-r61k6oim- :

09u98y9

JACUSTOMER-r61k6oim- :

hi

JACUSTOMER-r61k6oim- :

are u there?

JACUSTOMER-r61k6oim- :

pls answer my questions

JACUSTOMER-r61k6oim- :

i have 188,000 miles on it and i got the intake manifold cleaned out of carbons

HONDASERVICE7791 :

did the check engine light issue happen after the repair?

JACUSTOMER-r61k6oim- :

yes

JACUSTOMER-r61k6oim- :

before repair it came on for egr problem and it was diagnosed to be carbon deposited on the intake manofld and it was removed and done ,then i got new spark plugs of iridium

JACUSTOMER-r61k6oim- :

then check engine light went off for couple of months until just of recent that itjust pop up on and off

JACUSTOMER-r61k6oim- :

u there sir

JACUSTOMER-r61k6oim- :

hi

if the problem started after the repair then you will need to check the intake and associated parts to see if there is a slight vacuum leak causing this issue. Also you said you replaced the plugs, I'm hoping you used Honda genuine parts. these cars seem to get a finicky when you use other makers plugs.
Customer: replied 4 years ago.


I used NGK LASER IRIDIUM PREMIUM SPARK PLUGS


 

ok that should be fine. recheck the intake there has to be a vacuum leak there causing your codes
Customer: replied 4 years ago.


OK,BUT PLS IS IT D SOMETHING I CAN DO OR I HAVE TO TAKE IT TO A SHOP TO CHECK FOR ME AND HOW MUCH DO THINK IT CAN COST TO DO?


PLS WHAT ABOUT ABS AND TCS?


 

depending on who performed the job to begin with, i would say bring it back to whomever did the work. They should fix it for no charge. If you have to take it to another shop, i could not guess as to what it would cost to repair but if it is a different place they will at least charge you some diagnostic time. probably 1 hour time to start based on what their hourly shop rate is.

 

the abs/tcs light has to be checked for codes. it could be several things. with out the code it would be hard to guess. if you get the codes you can repost them here and i can help you further

HONDASERVICE7791 and 3 other Acura Specialists are ready to help you
Customer: replied 4 years ago.


thanks sir if i have any other issue i will let u know.


 

if you get the codes for the abs/tcs checked let me know what the codes are and i can guide you more on a solution.