How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, ASE Certified Technician
Category: VW
Satisfied Customers: 795
Experience:  Senior Technician
84449473
Type Your VW Question Here...
Gary is online now
A new question is answered every 9 seconds

Stop indicated on dash and then says oil press so i put in a

Customer Question

Stop indicated on dash and then says oil press so i put in a new oil pump and it still does it . so would it be my oil sending unit?
JA: When was your last oil change?
Customer: A week ago
JA: What is the model/year of your VW?
Customer: 2000 passat 2.8 v6 30v GLS
JA: Are you fixing your Passat yourself? What have you tried so far?
Customer: Yeah im doing it myself
JA: Anything else you want the mechanic to know before I connect you?
Customer: Its a used motor i put in a few months back
Submitted: 5 months ago.
Category: VW
Expert:  Gary replied 5 months ago.

Hi there,

Did you measure oil pressure first before replacing the oil pump?

Still the same, so could be a blocked pickup or failed sender.

Gary

Customer: replied 5 months ago.
I didnt check it
Expert:  Gary replied 5 months ago.

Ok, you need a gauge to measure the oil pressure.

If the engine is normal, then you are chasing an electrical issue, probably sender.

If the pressure is low or zero, then probably pickup related, so now sump off to inspect oil pickup.

Gary

Customer: replied 5 months ago.
Pickup related?
Expert:  Gary replied 5 months ago.

Can you hook up a test gauge, and we'll see the results, and then decide.

While the engine is running with the warning light on, is the engine noisy?

Gary

Customer: replied 5 months ago.
No not anything noticeable
Expert:  Gary replied 5 months ago.

Ok, it must have oil pressure if it isn't noisy, can you remove the sender and if it is wet with oil, it probably does have a normal functioning oil pump.

If you then bump the starter to see if oil does flow from the port.

If it does, I would still measure the pressure with an accurate gauge, then replace the sender.

Gary

Customer: replied 5 months ago.
Ok i ordered one
Expert:  Gary replied 5 months ago.

Ok, I'll hear back from you after you do this.

Gary

Customer: replied 5 months ago.
Ok its coming in the mail tomorrow
Expert:  Gary replied 5 months ago.

Ok, that's good.

Can you check there is some flow from the port with a crank from the engine before fitting the sensor?

Gary