How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Your Own Question
John, ASE Master Technician
Category: VW
Satisfied Customers: 608
Experience:  ASE Certified Master Technician, ASE Certified Service Consultant, 22 years professional experience
Type Your VW Question Here...
John is online now
A new question is answered every 9 seconds

2009 jetta lost all lights on right side. please help with

Customer Question

2009 jetta lost all lights on right side. please help with some kind of answer.
JA: Just to clarify, what are the exact lights you're talking about?
Customer: high & low beams, reverse light, turn signal front & back, (turn signal on side mirror still works).
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: light bulbs & fuses, all are good.
JA: Anything else you think the mechanic should know?
Customer: it started only 2 days ago, before all was good.
Submitted: 3 months ago.
Category: VW
Expert:  John replied 3 months ago.

Hello, my name is John.

This is a common problem and most frequently come back to the underhood fuse box. Poor connections occur insude the plastic fuse box and groups of fuses and relays quit working. The fuses will still be good because there are no shorts but poor connections cause the circuits to quit. You may even find some burnt or melted connectors. You might be able to turn all the lights on and wiggle some of the fuses and see the lights flicker on and off. If this happen then I would replace the underhood fuse box. If the lights still do not flicker then I would remove the fusebox for further inspection but I am confident that this is your fix. Please let me know if you need any further assistance from me on this problem.

Related VW Questions