How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190, Technician
Category: VW
Satisfied Customers: 24182
Experience:  Over 17 years diagnosing and repairing various model vehicles.
Type Your VW Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I have a 2006 vw jetta 1.9 tdi it has a p0102 code i have

Customer Question

i have a 2006 vw jetta 1.9 tdi it has a p0102 code i have replaced the maf sensor and the code pop back up immediately
Submitted: 3 months ago.
Category: VW
Expert:  peterpete190 replied 3 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Is the code coming back up as soon as the key is turned on with the engine off or does the engine have to be running when it pops back up?

Let me know so we can continue,thanks Pete.

Customer: replied 3 months ago.
after clearing the code it doesn't reappear at koeo but as soon as it fires it appears
Customer: replied 3 months ago.
i have also checked wiring and i have a 5v reference and proper ground
Expert:  peterpete190 replied 3 months ago.

Have you checked for any vacuum leaks?I have seen issues with vacuum leaks on the engine that will cause a mass air flow sensor code like this here and had to repair the leak.I have had to do a smoke test/inject smoke into the intake to locate any hard to see leaks like intake gaskets leaking needing replaced.If this has not been done I would have this done to see if it corrects the fault here.

If this is o.k. one other sensor that will cause a mass air flow sensor code is a faulty map sensor needing replaced.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 3 months ago.
i know its not a vacuum leak because watching the live stream it is reading no air flow at all
Expert:  peterpete190 replied 3 months ago.

O.k.,that helps allot there.

If you have the 5 volt signal and ground to the sensor but no signal to the computer this indicates the signal wire is either broken or damaged leading from this sensor to the computer or the computer itself has an internal fault and needs replaced.I have seen both cause this here before.

I would trace the wiring for any issues and if the wiring is found to be o.k. I suspect the engine computer itself will need replaced to correct this here.These are the only 2 things I see myself that will cause this fault.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.

Thanks Pete