How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask vwtech0405 Your Own Question
vwtech0405
vwtech0405, VW Technician
Category: VW
Satisfied Customers: 10640
Experience:  VW Master Technician VW Certified
22815973
Type Your VW Question Here...
vwtech0405 is online now
A new question is answered every 9 seconds

I have a 1997 Volkswagen cabio and have a check engine light

Customer Question

I have a 1997 Volkswagen cabio and have a check engine light and airbag light on .also when I try to connect a vag code reader it says no link. It has an aftermarket radio,but from what I can tell the k wire is cut from the loop what is causing these problems?
Submitted: 12 months ago.
Category: VW
Expert:  vwtech0405 replied 12 months ago.

Can you tell me what exact color is the wire thats cut and what pin # ***** ***** on the connector thats cut ??

Customer: replied 12 months ago.
It's a blue wire coming out of the back of the aftermarket harness. I have tried to remove the radio to see what happens and no change in lights or connection with scanner. Also tried different computer.
Expert:  vwtech0405 replied 12 months ago.
What color is pin #3 in the factory black connector ?
Customer: replied 11 months ago.
blue . I have even tried to disconnect the radio totally. When you start the engine , check engine light and airbag light are on solid and cannot connect with vag scanner .
Expert:  vwtech0405 replied 11 months ago.
You have a canbus communication issue do you have signal at the obd connector ?
Customer: replied 11 months ago.
Yeah the vag scanner gets power from obd2 connection. Says no link when try to scan
Expert:  vwtech0405 replied 11 months ago.

Have you tried a different scan tool ??

Customer: replied 11 months ago.
tried 3 actually
Expert:  vwtech0405 replied 11 months ago.

ok provide me the vehicles vin # ***** i can look up the wiring diagram for you

Customer: replied 11 months ago.
Yeah 3wba81e0wm810956
Expert:  vwtech0405 replied 11 months ago.
Is fuse 22 good it's a 10amp fuse
Customer: replied 11 months ago.
I have been through all fuses as far as I know ,I know the cigarette lighter works . Like I said the scanner gets power from obd2 port . I am wondering what the pervious owner did to this car .
Expert:  vwtech0405 replied 11 months ago.

i am stating the basics thats why i asked if thast fuse was checked , do you know if the scan tool will communicate with the instrument cluster or airbag module ??

Customer: replied 11 months ago.
No not the airbag module tried that too ,could a bad airbag module be causing all these problems?
Expert:  vwtech0405 replied 11 months ago.
A bad module can bring down the whole system that's why am trying to figure out which one may be bringing down the system
Customer: replied 11 months ago.
Well hopefully this weekend I was going to try .first disconnect negative then positive battery cable and disconnect harness from airbag control module . Then I will get back to you whether or not I can scan the computer for codes. Since both the check engine and airbag light are both on solid and cannot connect ,I am thinking the module might be holding the vag scanner from connecting with car . Also I know this car was in a wreck at some point in its lifetime.
Expert:  vwtech0405 replied 11 months ago.

no problem keep me posted

Customer: replied 11 months ago.
far I have removed the center console and a metal plate in front of a plastic box . I can see the wiring harness from the drivers side ,but have to remove plastic box. Once I disconnect the harness from airbag control module I am going to see if the engine light and computer will connect. That's why I am suspicious about the airbag module ,the light is on ,so it knows there is a fault in the airbag system. Maybe that module is making the system being down from connecting a scanner.
Expert:  vwtech0405 replied 11 months ago.
Ok good
Customer: replied 11 months ago.
Hopefully when I start the engine with harness disconnected the airbags will stay in since the wiring is removed from module
Expert:  vwtech0405 replied 11 months ago.

Yes they will

Customer: replied 11 months ago.
they will not deploy?
Expert:  vwtech0405 replied 11 months ago.
No they will not
Customer: replied 11 months ago.
Ok
Expert:  vwtech0405 replied 11 months ago.
Let me know when you have results
Customer: replied 11 months ago.
Ok disconnected airbag module still same cannot link
Customer: replied 11 months ago.
I did see something one time about on the scanner about k line ok
and other things don't know how it went into it