How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Technician
Category: VW
Satisfied Customers: 24729
Experience:  Over 17 years diagnosing and repairing various model vehicles.
14928985
Type Your VW Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

2009 VW GTI, I intermittently (sometimes several days apart)

Customer Question

2009 VW GTI, I intermittently (sometimes several days apart) get one of the two low oil indicators. Usually they appear and go right away but they have also stayed until the motor was turned off. I have had the oil sensor replaced and also put in a new oil pump. This always seems to happen when the rpm are between 1,400 and 1,700. I don't recall it ever happening outside of this range. I had a pressure gauge hooked up and the pressure was within the normal range. What is going on? Thanks.
Submitted: 9 months ago.
Category: VW
Expert:  peterpete190 replied 9 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Your computer usually shouldnt be checking the engine oil level with the engine running.I know some models had a software issue in the engine computer that would check the level with the engine running and a dealer had to update the software to correct this from occuring.The engine oil level is only checked with the key on and engine off.

If this engine for some odd reason is designed to check the engine oil level with the engine running and you have replaced the engine oil level sensor I would have the wiring checked to the sensor for any issues and if found o.k. it is possible there is sludge build up in the cylinder heads keeping the engine oil from draining back fast enough which will cause the low oil level indicator.

I would check for new software first to make sure this isnt the cause here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related VW Questions