How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Your Own Question
Mike
Mike, VW Mechanic
Category: VW
Satisfied Customers: 39198
Experience:  34 Years of working on vehicle repair & Diagnostics ! ;)
9261905
Type Your VW Question Here...
Mike is online now
A new question is answered every 9 seconds

I have 97 golf 2.0 no spark from coil I have injector puslse

Customer Question

I have 97 golf 2.0 no spark from coil I have injector puslse have power and ground across 3 wire at coil but when I roll engine over only get one hot spark at coil wite to ground
Submitted: 1 year ago.
Category: VW
Expert:  dr914jr replied 1 year ago.

Sounds like you have a failed reference mark sensor. I would pick one up at the local parts store and stick it in myself. Should be an easy fix.

Expert:  gomi_otaku replied 1 year ago.

I bet it arcs every time right when you let off the key- common problem with the ignition switch. The starter circuit is energized but not the ECM circuit.

Customer: replied 1 year ago.
installed reference sensor still no start installed ignition switch no start has new coil ???
Customer: replied 1 year ago.
I have injector pulse pos grnd at coil three wire only one flash on center wire
Expert:  Mike replied 1 year ago.

Hello and Welcome -

My name is***** happy to help / advise. The previous expert has opted out of this question.

Let me know exactly where you are up too on this and then we can progress... What has been mentioned is a common issue - that of a faulty ignition electrical contact switch - replacement is the only answer if that proves to be the case... Other than that - you can have a bad connection on the ign circuit or a faulty sensor.

Let me know how you go..and / or let me know if you need anything further on this..

~>>~~>>~ Meanwhile now - Please do click on the "Exc / Ok rating" for me at this time.. "Thank you" in advance for that .

.. Note that you can get back to me anytime at all after doing the rating - it doesn't close you out --

Best Rgds, MIKE

Customer: replied 1 year ago.
New reference sensor new ignition switch still no start one spark then nothing
Expert:  gomi_otaku replied 1 year ago.

Let's do a test- set up the center wire from the coil to the distributor to do a spark test. You want to test from this main wire instead of a plug wire as this test will not involve cranking the engine.

Disconnect the distributor, you will be addressing the three pin connector you have disconnected.

The distributor has a hall effect sender, with a magnet and a toothed wheel. This creates a pulsed signal. You will be taking the distributor out of the equation, creating this signal yourself, to test the other parts of this system.

So, with the key on, using a wire jumped directly from battery positive, tap RAPIDLY on the center pin of the connector. You should see the spark arc, as you are sending the signal to the ECM.

Expert:  Mike replied 1 year ago.

Hello again -

I dont know why the expert that answered you before, the one that opted out, has come back in again.. I have asked him bit received no response -

Too - you have not replied to me at all re what I said above - if you want / need to carry on with this please just let me know, or you can opt to close the question.

Rgds, MIKE.