How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask vwnewton Your Own Question
vwnewton
vwnewton, VW Owner,ASE Master and L1 Advanced
Category: VW
Satisfied Customers: 307
Experience:  25 years of VW obsession turned into a job, last 15 years as a VW Tech.
13710235
Type Your VW Question Here...
vwnewton is online now
A new question is answered every 9 seconds

I have a 2012 jetta tdi. Out of the blue it stalled on me as

Customer Question

I have a 2012 jetta tdi. Out of the blue it stalled on me as i was driving. Flashed the glow plug light while sputtering then died. waited a few minutes while checking connectors and such under the hood and it restarted. did it a few more times within a span of a few hrs then had to be towed home. Codes are P2017 P2100 P2102. Car runs and starts when cold and dies when it warms up.
Submitted: 1 year ago.
Category: VW
Expert:  Wolfgang replied 1 year ago.

Thanks for choosing Just Answer . I'm Wolfgang here to help!!
Below is my first answer or request for more information. If you do not understand it, or you need more information from me, or need me to go in more detail. Do not rate yet, just reply. Put yourself in my shoes, I can not see, smell, hear, feel or touch your car, nor do I know any history on it. So take into consideration I am doing my best based on what you tell me. Also understand fixing cars often requires sophisticated tools, that you may not own. So even if you can not do what is outlined in my answer, that does not mean my answer is wrong deserving to be rated negative.

i do need a vin # ***** the vehicle and also how many miles are on the vehicle please

thanks

Customer: replied 1 year ago.
3VWLL7AJ3CM426073
96K MILES
Expert:  Wolfgang replied 1 year ago.

thanks for the info . if you take the engine cover off and in front you have the intake manifold then you have a flap valve then another flap valve . i need you to look at the wiring of the lower flap valve and inspect if there is any rubbing of chaffing of the wires . is the wiring tight or loose and the connector is snapped on.

was there a recent accident or repair work to the vehicle?

Customer: replied 1 year ago.
The wiring to the shutter valve is clean is firmly connected with no chaffing.
The last thing that was done was a new turbo but that was over 2 months ago and the car ran like a top.
I did degrease the engine at the car wash the day the issues started and believe that has something to do with the issue.
I have been working on car my entire life so im fairly saavy under the hood but I just cannot pinpoint this issue.
Customer: replied 1 year ago.
maybe TAC relay? I do not know the location of that relay if so...
Customer: replied 1 year ago.
I have pulled the throttle control valve. I was not sticking and the flapper moved freely. I havent found a blown fuse which makes sense because the motor can actuate the flap freely. Lets say the relay is bad causing the codes. Would the engine still die just because the computer isnt seeing the proper values from the TAC? Because I removed the actual flap from the valve to see if that was the cause. Obviously its not because the engine still dies after a few minutes. Maybe it cuts fuel as a failsafe?
Expert:  Wolfgang replied 1 year ago.

that flap cuts the air and if there is garbage readings it will place the vehicle in limp mode and worse case stall the engine. so tracing of the wiring is needed . what happens if the codes are cleared does it run then and the codes resets right away?

what scan tool are you using please? make and model

Customer: replied 1 year ago.
I am using the PLX DM-100 OBD. It is a gauge with a generic OBD scanner in it. Yesterday My buddy had VagCom on it ant was throwing 1 and 4 injector circuit fault.
When I clear the codes it will not restart. Once it dies I have to wait an hr or so for it to restart and run for a few minutes then stalls again.
Customer: replied 1 year ago.
I do not recall the exact codes vagcom gave us
Customer: replied 1 year ago.
is there a way to test the TAC?
Expert:  Wolfgang replied 1 year ago.

TAC ? CAN YOU EXPLAIN?

Customer: replied 1 year ago.
Throttle Actuator control. It's no longer giving me those codes. Now its p201 and p204. So i ohmed the injectors and they ohmed in spec. Now I'm checking the resistance on the harness.
Expert:  Wolfgang replied 1 year ago.

the tac is a flap to shut the air off to the engine. the only way to check is the wiring from tac to the ecu if all good and no crosses then tac needs to be replaced. sorry mind went blank too early in the morning!!

Customer: replied 1 year ago.
Well its no longer giving me that code anyway
Expert:  Wolfgang replied 1 year ago.

do you still have then the stalling issue?

Customer: replied 1 year ago.
Injectors ohmd good. Harnes from injector to ecm checked good. I'm going to change the battery in the key fob to rule out the immobilizer.
Expert:  Wolfgang replied 1 year ago.

i would recommend to get vag com to scan all modules and post full module scan here please so i can have a look see of this myself. the generic scan tool will not help i need to see measured readings while the engine is running to have a game plan what to test .

Customer: replied 1 year ago.
welp scanned it again with vag com and just gave me 1 through 4 injector circuit malfunction. Since I went over everything physically and the probability of all 4 injectors being bad is pretty slim I pulled the ECM and opened it. Water corrosion inside of it. getting a used one tomorrow so we shall see.
Expert:  Wolfgang replied 1 year ago.

you will then need to go to the dealer to program the immobilizer to the ecu. all keys need to be resent to do this reprogram