How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask vwnewton Your Own Question
vwnewton
vwnewton, VW Owner,ASE Master and L1 Advanced
Category: VW
Satisfied Customers: 307
Experience:  25 years of VW obsession turned into a job, last 15 years as a VW Tech.
13710235
Type Your VW Question Here...
vwnewton is online now
A new question is answered every 9 seconds

2010 vw routan ..weird electrical problem .. dash lights

Customer Question

2010 vw routan ..weird electrical problem .. dash lights stay on when running... any ideas? wipers would just wipe randomly ..thks
Submitted: 1 year ago.
Category: VW
Expert:  vwtech0405 replied 1 year ago.
You are dropping a system in the can bus system which faults do you have in the system ?
Customer: replied 1 year ago.
gas gauge doesn't move and yellow gas light is on.. replaced fuel pump unit, still no movement from gauge. putting back original pump. Have tank down. Any test i could do while wiring is exposed? 3 possibility now right? short in wiring? module? or instrument cluster ? code i have is p0463 fuel level sensor 1 circuit high ... Any help would be greatly appreciated
Customer: replied 1 year ago.
have a decent scanner with oem capability if that helps
Expert:  vwtech0405 replied 1 year ago.
You stated 2 different issues here your original
Question stated about wipers and dash light staying on and now you have stated something about the fuel system .
Expert:  vwtech0405 replied 1 year ago.
I have submitted a offer for me to give you a call on the issue of you would like to solve the issue faster please accept the offer I can call you directly at a phone # ***** provide me then it's easier this way
Customer: replied 1 year ago.
ok
Customer: replied 1 year ago.
cost is 10 $?
Customer: replied 1 year ago.
even if u have unlimited question membership?
Customer: replied 1 year ago.
sorry that's my main concern the fuel issue
Expert:  vwtech0405 replied 1 year ago.
Let me ask you this all this happen at the same time especially the wiper issue ?
Customer: replied 1 year ago.
not really.. changed the battery because old one wasn't holding voltage.. thats when wiper acted funny when voltage was low. My main concern is the fuel level gauge not working... I might have an other body control module from an other car.. Where is it located?
Expert:  vwtech0405 replied 1 year ago.
Its called the TIPM module located under the fuse box under the hood .
Customer: replied 1 year ago.
Thank u
Expert:  vwtech0405 replied 1 year ago.
When you replace the fuel pump did you also replace the sending unit ?
Customer: replied 1 year ago.
Yes it's one piece
Customer: replied 1 year ago.
It was a Delphi pump. Not oem
Expert:  vwtech0405 replied 1 year ago.
Have you checked the wiring from the sending unit to the cluster ?