How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Danny Your Own Question
Danny
Danny, VW Mechanic
Category: VW
Satisfied Customers: 4004
Experience:  ASE Master Certified with L1 Certification, Volkswagen Certified, VW and Audi repair shop owner
13195203
Type Your VW Question Here...
Danny is online now
A new question is answered every 9 seconds

1997 VW Golf: leaking oil around where the oil filter goes in, can you

Resolved Question:

I have a 1997 VW Golf, it seems to be leaking oil around where the oil filter goes in, can you give me some idea what the problem may be?
Submitted: 8 years ago.
Category: VW
Expert:  Danny replied 8 years ago.
Customer

The problem is either a leaking oil pressure sender which is right there on the oil filter housing and can be easily checked by seing if it is leaking oil, or it's the oil cooler seal. If you can see it leaking from the place where the oil cooler (the big metal square block the oil cooler spins onto) meets the filter housing bracket on the block then it's that seal. You replace it by removing the oil filter, then removing the large nut that screws onto the post that the oil filter screws onto. Then you can drop down the cooler and replace the seal. The seal is $10 I think and the oil pressure sensor is probably less than $20. Good luck

Danny
Danny and other VW Specialists are ready to help you
Customer: replied 8 years ago.
The oil runs right out around the filter as soon as you start the car, it doesn't seem to run out until the car is turned over. I put 2 quarts in the car and just turned the engine over and it started running right out, do you believe this may be the problem. I drove the car home from work last night and there didn't seem to be any problems, this morning I went out and started it and let it run for about 5 minutes to warm up , when I got in it the oil pressure light was on so I shut it off thining maybe it was because it was sitting runing. I stated it up and pulled out of the drive and it started beeping so I backed in drive and shut car off, there was no oil in it. There was oil all over the motor and under neath the car. I had a problem with the oil pressure sensor lat year and replaced it, thinking maybe it was the same problem,but the sensor was dry.