How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Volvo
Satisfied Customers: 7067
Experience:  Since 1975
12769047
Type Your Volvo Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

2008 Volvo XC90 3.2 Front Wipers only function at high

Customer Question

2008 Volvo XC90 3.2 Front Wipers only function at high speed. I already replaced the switch for the front wipers, the wiper motor, checked all fuses and relays they are all fine. What else should i look/check for?
Submitted: 5 months ago.
Category: Volvo
Expert:  rpmdiag replied 5 months ago.

Hi, I'm Ron and I will be helping you today.
Stand by for a moment while I prepare your answer.

Customer: replied 5 months ago.
Thank You Ron!
Expert:  rpmdiag replied 5 months ago.

Okay, so if the switch is good, the motor and wiper module are all that's left.

You can check this with a scan tool in bidirectional mode to confirm which is bad.

Thanks, Ron

Customer: replied 5 months ago.
where is the wiper motor module located? If the module is indeed the problem, once replaced does it need to be programmed?
Customer: replied 5 months ago.
can you send me a diagram of the location and how to check if that is our problem.
Expert:  rpmdiag replied 5 months ago.

After looking again, they changed this and you don't have a module that is separate for the wiper motor any more, you just have a relay in your relay box under the hood. I don't think it controls speeds though, just functionality which would mean that the wiper motor is what's bad.

thanks again and please remember to rate me 5 stars and keep this link in case you need me again later on.

Ron

Customer: replied 5 months ago.
The wiper motor was already replaced, we still have the same issue. Is there any diagnostic procedures that you can send me to troubleshoot this issue. Thanks
Expert:  rpmdiag replied 5 months ago.

There is not for that problem, make sure that the wiring is good at the connectors, especially the grounds.

They only supply troubleshooting data when a code exists in the computer.

You would still be best off to check it with a scan tool like I said before, because you can also have a problem with the BUS line. The scan tool will tell you everything.

Thanks, Ron

Expert:  rpmdiag replied 5 months ago.

I apologize for having to give you that news, and I sure hope it doesn't affect my rating. I'm just the messenger:)

Thanks, Ron

Customer: replied 5 months ago.
There is no problem with the bus line... All grounds checked out ok. I need someone with more expertise. So far you haven't giving me a diagnostic procedure. Just guessing.
Expert:  rpmdiag replied 5 months ago.
Use the scan tool, there's no guesswork when you agree to do it right.
Expert:  rpmdiag replied 5 months ago.

I'm not sure if this will help you, but I sent you this wiring diagram anyway.

The scan tool really is the best and easiest way to find the problem though. let me know if you need anything else:)

thanks again, Ron

Expert:  rpmdiag replied 5 months ago.

Hi, I'm just following up with you to see if you have any more questions.
Thanks, Ron

Related Volvo Questions