How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Volvo
Satisfied Customers: 44424
Experience:  16 years of experience
2499435
Type Your Volvo Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 2004 (Early) Volvo s40 I have had lighting problems

Customer Question

I have a 2004 (Early) Volvo s40 I have had lighting problems in the past mainly with my headlights and I was able to resolve them by purchasing a new Central Electronic Module but recently my passenger side turn signal marker light and one of the brake light bulbs suddenly no longer work well the blinker and marker light blink when i turn my blinkers or hazards on but they will not just stay lit like they are supposed to when driving I tried replacing the bulbs and that did not fix the problem I also bought another CEM and that also did not fix the problem has anyone else had this issue? What else can i do?
Submitted: 3 months ago.
Category: Volvo
Expert:  Chris (aka-Moose) replied 3 months ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.working after noon till just after midnight.

  • Sorry no one has helped yet.
  • Yes, you have been charged already.
  • Yes, I am aware of the time you asked your question and time I am responding.
  • I will be online a couple more hours after this post.
  • This is not an answer to your question, just an inquiry if your still needing/wanting help. Because I believe I can help.
Customer: replied 3 months ago.
I am still needing help with my Issue what is your opinion?
Expert:  Chris (aka-Moose) replied 3 months ago.

Passenger side marker light will not illuminate, is that the front or rear?

Which brake light does not work?

Here is a link to the diagrams I will be using to help figure this out. https://dl.dropboxusercontent.com/u/90220402/S40.pdf

This is my 1st answer, but does not have to be my only answer. You the website and myself expect you to have a great experience with my help. Please let me know if you are pleased by selecting a star rating above or by replying and saying your pleased. Not rating or rating 1-2 stars does not benefit you nor me in any way. Follow up and reply as often and when needed, there is no extra charge to do so.

Thanks Moose.

Customer: replied 3 months ago.
The lights that are not working are the front blinker light (the one next to the main headlights), and one of the two light bulbs in my rear brake lights all on the passenger side I have come to the conclusion that the side door marker lights do not stay on as markers when I turn on the car that they are only used when turning.
Expert:  Chris (aka-Moose) replied 3 months ago.

In the instrument cluster is the right turn indicator flashing with the right turn signal on?

The RR lamp that is not working, is that the turn signal?

Customer: replied 3 months ago.
The blinker indicator in the instrument cluster works as it should when the right turn signal is turned on the rear light is the brake light that isnt working well not the brake light itself but one of the two brake light bulbs that come on when you start the car the actual brake lights work fine there is no safety issue when it comes down to it the brake lights work when i press the brake and the blinkers blink but they do not illuminate as marker lights like they do on the drivers side. I have included an image of the back lights of a Volvo similar to mine the lights that arent working in the back is one of the two light bulbs that are in the top illuminated part of the brake light housing the actual brake lights in the model are on the bottom left/right half of the housing respectively and work fine.