How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Enes Your Own Question
Enes
Enes, VOLVO Master Technician
Category: Volvo
Satisfied Customers: 4903
Experience:  15+YEARS WITH VOLVO AS THE MASTER VOLVO MECHANIC&Ase
20168386
Type Your Volvo Question Here...
Enes is online now
A new question is answered every 9 seconds

Ok- so 2004 XC70, Vin: YV1SZ59H341129378 Mi: 108154 Came in

Customer Question

Ok- so 2004 XC70, Vin: YV1SZ59H341129378 Mi: 108154
Came in with crankshaft speed sensor code (dont have the code written down) with symptoms of intermittent stall when hot (sensor right?)...
Replaced crankshaft and camshaft sensors. Car started and ran beautifully until it stalled when I put it in gear and has not started since- timing belt is tight, has fuel pressure, no spark, I have both keys, inspected ecu/tcu, inspected wiring, battery is at full charge, and last but not least- not one code in the vehicle (scanned with Autologic). If I watch the actual values, the crankshaft rpm signal is intermittent under cranking. (rpm:0....200...0...450...0...300..)
I am at a loss.
Submitted: 4 months ago.
Category: Volvo
Customer: replied 4 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Edward replied 4 months ago.

Hello, Eddie here, does it have injector pulse ? and there isn't a "START PREVENTED" or IMMOBILISER mesage is there? Can you check the codes in the CEM as well as the ECM? thanks.

Customer: replied 4 months ago.
Hey Eddie, and thank you for helping.
So- there is no start prevented or immobilizer message at this time. I have no injector pulse and i have no engine code after cranking it with just the noid light in... the CEM shows no errors as well. The only codes in the whole car are 0004 siren communication fault and 0025 door mirror disconnected: signal missing. forget to mention that I have both keys for the vehicle.
Expert:  Edward replied 4 months ago.

Alright , Does it have spark when cranking?

Customer: replied 4 months ago.
No spark under cranking
Customer: replied 4 months ago.
Check engine was flashing infrequently while cranking also
Expert:  Edward replied 4 months ago.

Has the transmission just been replaced when this problem occured? Also, did it die going down the road by chance? or did it just not start after parked? thanks.

Expert:  Edward replied 4 months ago.

Does the tach bounce around when cranking?

Customer: replied 4 months ago.
Well- customer was driving and it and it conked out- and it ran after i replaced the sensors crank/cam... Now as for the trans- i looked it over... it does not look like it was ever pulled from the ca, i could not see any witness marks on any major bolts. However- there is some pink goop that the upper pan was resealed. Tach has bounced, but it has not really done it recently
Expert:  Edward replied 4 months ago.

Alright, only reason I ask is, alot of times the reman trans. is painted, and paint against the trans. and bellhousing was causing this problem, So if it hasn't been out in a good while, that is not the culprit.

Expert:  Edward replied 4 months ago.

The check engine light does come on solid with key on correct?

Customer: replied 4 months ago.
KOEO the light has flashed if you leave it on-
Expert:  Edward replied 4 months ago.

It flashes and doesn't stay on solid?

Customer: replied 4 months ago.
but is mostly solid
will sometimes flash under cranking
Expert:  Edward replied 4 months ago.

with just the key on? it should stay lit up solid.

Customer: replied 4 months ago.
flash, then stay solid when done flashing
Customer: replied 4 months ago.
I will be right back- I have a customer crying about a slipping clutch
Expert:  Edward replied 4 months ago.

Alright, How bout power to the injectors? at the GREEN wire at any fuel injector. check for 12 volts with key ON, see if you have a constant 12 volts with key on. you should. Let me know what you find there.

Customer: replied 4 months ago.
yessir- 12.37V
We are closing up for the night down here- are you going to be available tomorrow?
Expert:  Edward replied 4 months ago.

Yes, tom. is good. We will try and figure it out. thanks.

Customer: replied 4 months ago.
Hey Edward, I'm back- let me know when you are around.
Expert:  Edward replied 4 months ago.

Hello, Do you have the tool that Volvo thought was a great idea to get this ECM in and out of the computer box under the hood? I would like to take it out, and make sure there isn't corrosion on the pins.

Expert:  Edward replied 4 months ago.

What happened with this one? Did you ever get it to run? Let me know, thanks.